Hello Guest it is November 12, 2019, 05:26:03 AM

Author Topic: Spindle speed non-responsive  (Read 879 times)

0 Members and 1 Guest are viewing this topic.

Spindle speed non-responsive
« on: June 01, 2017, 05:51:11 PM »
I am new to everything here so please bear with me.  I just got this cnc conversion (was a cnc prior) running today and seem to have run into a wall.  When I try to adjust spindle speed with the MDI and the main screen (alt 1) with the feed rate override there is no difference in spindle speed.  Also It doesn't seem to matter if I type in a speed in the rpm box below it always runs the same rpm.  I am guessing I have something messed up in settings I just can't find it.  The VFD can control the speed when running the machine from the VFD so I think I have that set correctly.  I searched the forums for quite a while and checked over some things however I have yet to find a solution.  Any help is greatly appreciated.

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: Spindle speed non-responsive
« Reply #1 on: June 03, 2017, 09:26:35 AM »
Please provide more details of what you have so others can help you
Nicolas
Re: Spindle speed non-responsive
« Reply #2 on: June 05, 2017, 08:40:50 AM »
I have a Mitsubishi FR720D VFD, PMDX 126 and 107 boards and Mach III software.  I think the problem is with some of the VFD settings however I am having problems getting some of the parameters set, I am sure at this point it is a problem with the parameters...just trying to figure out where.  I am unable to get PR73 to change to where it should be so I am thinking there is an additional PR that needs to be set I just can't figure out which one.

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: Spindle speed non-responsive
« Reply #3 on: June 05, 2017, 09:30:37 AM »
Not familiar with the Mitsubishi / PMDX but if you post how they are connected together you will get more help.

I have a Chinese VFD with the G540 controller and have 2 sets of connections between the VFD & G540. One is to turn the VFD ON/OFF and the other is for the speed of the spindle. Since your spindle turns but you are not able to control the speed it sounds you are missing one set of connection.

The RPM box on Mach3 functions only if you have an Index (don’t know how this really works but on my cnc I decided I don’t need it). All I do I type my speed on MDI (ALT2) screen like M3S18000 and I get 18000 RPM on my spindle. If your spindle is connected right the gCode will turn the spindle ON/OFF.

Since I have no use for reverse speed I have left the reverse parameter on my VFD to 0
Nicolas
Re: Spindle speed non-responsive
« Reply #4 on: June 05, 2017, 09:33:46 AM »
The guys at Mitsubishi are great to work with.  I called them this morning and they told me I had the voltage wires incorrect.  I was right according to what I read in the manual however as soon as I made the change it is working.