Hello Guest it is June 27, 2019, 01:39:50 AM

Author Topic: CNC Router Super Jerky  (Read 839 times)

0 Members and 1 Guest are viewing this topic.

CNC Router Super Jerky
« on: June 01, 2017, 01:56:56 PM »
Hoping someone on here can help me,,,

I have a 4x8 CNC router Ipicked up a couple of years ago - it's a home built jobber by somebody, steel frame, and not the best design. I have used it a lot though, and have been nursing it along - hopefully I'll be able to replace it with a better one, but I'm not there yet, so need to keep this one alive for a bit longer if possible.

The latest 'upgrade' I did to it was to replace the Z axis to a better setup, which seems to be working fine, and to regear the X axis/the motor driving it across the gantry. The old design (and still currently my 'Y/A axis), ran on direct drive rack and pinion. The backlash in the direct drive always gave me problems, so I swapped the X axis to a CNC routerparts 3:1 belt drive reduction unit, which holds the pinion against the rack under spring pressure. I recalibrated my steps, and gave it a test. It jogs just fine up to 600 IPM or so, which is plenty fast for me. It moves around by hand, with no power to it, without binding. But when running G code it acts horrendously. On curves it stutters so badly the machine is shaking. On straights it runs better, although still a little rough, but every now and then it still jerks - especially when it''s approaching a corner, but sometimes in the middle of a straight. It does it in the X axis, or the Y axis. I think the Z is fine, although it's hard to tell since it moves so much less.

I am running Longs DM542a drives, with a DB25-1205 breakout board. Windows 7, 32 bit, Mach 3, no external motion controller, just running off the BOB. Motors are NEMA 23 23hs45-4204s like these:
https://www.amazon.com/Torque-Stepper-Motor-425oz-Router/dp/B00PNEPW4C

I have my kernel at 25000, but have tried it all over the place with not much different results. I've tried my microstepping in a few different configurations, including 400 or 800 for the X axis (the one geared 3 to 1 with a 1" pinion, 20 degree pitch on the rack) and 800 and 1600 on the Y-axis. I'm not exactly sure what this equates to in terms of microstepping (can someone elaborate on that?).

I think it has to do with my computer, or maybe my BOB died... I had a similar problem before when the computer was trying to talk to windows and update itself when I had it networked. Now it's disconnected from the internet. I have run the drivertest file, and it hovers around 25000 pretty stable. My CPU usage doesn't ever seem to spike over 12%.

I've tried it on multiple G code files, all which I've ran before with no problems.

Argh, any idea on what's causing this now? I'm going a little crazy. Can anyone tell me where I should set my kernel and microstepping for a good/conservative start? somewhere that it 'should' work with velocity around 200 IPM? And why does it do it only under G-code, but not while jogging? Ugh...

Dameronw
Re: CNC Router Super Jerky
« Reply #1 on: June 01, 2017, 03:43:40 PM »
Also, CV mode is enabled, and 'look ahead' is set to 200.
Re: CNC Router Super Jerky
« Reply #2 on: June 04, 2017, 06:14:22 PM »
I don't know if this is your problem but I had something similar going on and could not find it anywhere.  I knew it was my config because I did not make any hardware changes.
Check under "General Config" constant velocity parameters. Not the "Motion Mode" in the center of the screen (this usually should be set to CV Mode)  but the "CV Control" check boxes at the lower right.  I'm not sure exactly what I did there :) but whatever I did it worked.
It's worth a shot to take a look.  Let me know if this helps.

Bart
Re: CNC Router Super Jerky
« Reply #3 on: June 04, 2017, 09:59:48 PM »
I would be concerned that the 3 to 1 reduction which multiplies the motor torque by 3 times also requires that the motor runs 3 times as fast for the same travel speed. Then you may be exceeding the capability to put out steps reliably. Or the motor torque simply falls off so fast that you actually have less torque rather than more, again losing steps.