Hello Guest it is October 23, 2019, 02:56:51 PM

Author Topic: Unable To Get Servo Movement  (Read 801 times)

0 Members and 1 Guest are viewing this topic.

Offline Katoh

*
  •  274 274
    • View Profile
Unable To Get Servo Movement
« on: May 22, 2017, 03:32:00 AM »
Hi friends
Just lately I replaced my lathe spindle induction motor with an AC servo, I purchased a new motor and matching driver. I also went to Smoothstepper ESS rev 2 to replace the two parallel ports I was previously running.
I have configured the ESS with little difficulty and everything works as it should, X, and Z axis both move and inputs and outputs work just fine. Now for the spindle side of things, I have read the manual and double checked all, but can not get any response from the servo motor at all. I have read through some old posts in using a servo as a spindle and followed all the information from there but nothing will happen. Where am I going wrong.
My set-up in ports and pins is as follows  I am using Spindle step pin 1, direction pin 14 both port 1, and have tried both low and high. Motor tuning Steps is 10000, speed 2500
Acc 40. On the smoothstepper I have ticked use Step/Direction and frequency is 516Khz.
From port 1 I have a wire going from pin1(step) to pin 6(driver) pin14 to pin 7(driver) as per manual, I also have +12v to pin 18 and 19(driver), another +12v to pin 8(driver) The negative(neutral) to pin 21(driver) and get absolutely nothing!
Attached are the set-up pages from the driver manual, I have configured this based on pages 12 and 21
Maybe somebody can point in the right direction.
« Last Edit: May 22, 2017, 03:43:54 AM by Katoh »
Cheers
Katoh

Offline Katoh

*
  •  274 274
    • View Profile
Re: Unable To Get Servo Movement
« Reply #1 on: May 22, 2017, 03:48:35 AM »
Sorry this is the correct page that I used to wire up the Driver, its the one in the middle on page 21 using the plus 12v input on 18/19.
Cheers
Katoh

Offline Katoh

*
  •  274 274
    • View Profile
Re: Unable To Get Servo Movement
« Reply #2 on: May 22, 2017, 06:28:31 PM »
Hi Friends
I found a PDF of the proper manual for the drive, thais might make it it a little easier to look at.
Cheers
Katoh

Offline Katoh

*
  •  274 274
    • View Profile
Re: Unable To Get Servo Movement
« Reply #3 on: May 23, 2017, 06:11:00 PM »
Quick update
I finally have movement somehow? Wiring is the same as it was but can only turn the motor in one direction. Have tried different ports and pins but still cannot get the motor to reverse. It is almost like it has no direction command.
One other thing that is happing Is I can only get the motor to half its rated speed, 2500rpm is max anything to 1250 works fine but after that it fails. I have tried changing its speed in pulleys and in motor tuning but can not get more than that 1/2 speed no matter what. I even tried setting full speed at 1200, still will only give me half 600rpm before failing.
Must be a parameter or setting I am missing in the servo driver.
Cheers
Katoh

Offline Katoh

*
  •  274 274
    • View Profile
Re: Unable To Get Servo Movement
« Reply #4 on: May 24, 2017, 03:48:43 AM »
Hi Everyone Im putting this thread to bed now.
whole issue ended up being a doggy 26 pin cable, Still one issue to resolve but I will start another topic for that.
Thanks.
Cheers
Katoh