Hello Guest it is May 08, 2021, 07:10:04 AM

Author Topic: Emergency Mode Active - MX4660 with UC100 USB Controller  (Read 1459 times)

0 Members and 1 Guest are viewing this topic.

Emergency Mode Active - MX4660 with UC100 USB Controller
« on: May 21, 2017, 07:50:46 AM »
Hello, I have been using the MX 4660 with the UC100 USB controller for the past couple of years on my XZero Raptor CNC router table. Yesterday, while running a job, I had to hit the emergency stop as the gantry was heading somewhere stupid due to an error in my set up. (The spindle is still in the middle of the table though, so there are no limits tripped.)  No big deal, I have had to hit it in the past.

However, now Mach3 will not “reset” emergency mode. When clicking Reset, nothing happens. I cannot clear emergency mode, it always reads “Press Reset – Emergency Mode Active."
On the MX 4660 I am blinking red.

Below are some steps I tried to trouble shoot the problem but to no avail. After each step that failed, I reset everything back to the original settings to move on to something else. (I left the estop pins shorted on the MX4660 however.)

1.       I removed my estop button on my machine and jumped the E-Stop pins on MX 4660. Mach3 still shows emergency active and will not reset.

2.       I disabled the Estop in mach3 Input signals section. Now, mach 3 will reset the emergency mode, but the steppers will not work. Mach 3 shows movement in the DRO, but no movement on the machine.

3.        I replaced a backup file from when it was working fine from the Mach3 xmlbackups folder to the Mach3 folder. That did not change anything. Still unable to reset emergency mode.

4.       I disabled all the limit switches as well as the estop in Mach3 Input Signals section. Again, I was able to reset mach3, but the steppers do not move even though the DRO in mach3 shows movement.

5.       I checked the active low section on the Estop output signal section in mach3. I was able to reset mach3, but no movement.

6.       I have cleaned and checked all the connections to and from the computer to the MX4660 as well as from the MX4660 to the machine.

7.       I had backed up the entire Mach3 folder on my computer last month and even replaced the current Mach3 folder with the backup files. Nothing changed.

8.       I am sure I have tried other things, but they do not come to mind at this point.

It is probably something simple (in your guys world) but I am totally stuck and would love any insight. I don’t know if there is a fuse inside the MX4660 that might have been tripped or if there might be another problem. Any help would be greatly appreciated.

The good news is now I know why CNC router tables are made so sturdy and heavy… if they were any lighter it would have been thrown through the shop window hours (days) ago.

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Emergency Mode Active - MX4660 with UC100 USB Controller
« Reply #1 on: May 21, 2017, 08:50:23 AM »
Are you sure that the MX4660 isn't the problem. I've seen a lot of posts where using the E-Stop button has damaged the MX4660, from the back EMF of the motors.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Emergency Mode Active - MX4660 with UC100 USB Controller
« Reply #2 on: May 21, 2017, 09:45:45 AM »
Hi Gerry,
Thanks for the response. Yea, I am covering that base as well. I have a support email request into Leadshine on the possibility that the MX4660 is the problem. I will probably purchase another one to verify but thought I would try this forum as well as it is a little less expensive than a new controller and I am still pretty new to all this. Overlooking something simple is certainly in my wheelhouse.