Hello Guest it is January 19, 2020, 09:56:38 PM

Author Topic: G1 Y... commands sometimes ignored  (Read 2931 times)

0 Members and 1 Guest are viewing this topic.

G1 Y... commands sometimes ignored
« on: May 15, 2017, 06:41:58 AM »
I have a new setup on Windows XP with typical parallel controller board on a mill drill which I converted to CNC.  After installation and setup it worked fine. I made a few parts with hand coded G code.  Then for no reason the system would sometimes not drive the Y motor for G1 Y... commands.  In fact it would not do G0 Y..., G2, G3 (Y direction) or jog in the Y direction either.  Actually the Y position in the Mach3 display changes correctly but the Y motor does nothing.  If I then move the X axis by G command or jog, the Y movements work again.  Later for no apparent reason the Y movement would not work again.  I do not get inaccurate movement - the movement either works correctly or not at all.  Is this a known problem and is there a fix to solve it?
I have tried the usual fixes like restarting Mach3, rebooting the PC and reinstalling Mach3 without a saved config and reconfiguring from scratch.

Offline Tweakie.CNC

  • *
  •  8,088 8,088
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: G1 Y... commands sometimes ignored
« Reply #1 on: May 15, 2017, 07:03:04 AM »
If your Mach3 Y axis DRO indicates the movement but the stepper motor does not move then you need to look at your wiring.
It could be a bad LPT cable (or connector) between your PC and controller or between the controller and stepper motor. The problem could also be within the controller itself so check everything (cables, connectors, wiring, etc.) thoroughly.

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: G1 Y... commands sometimes ignored
« Reply #2 on: May 15, 2017, 09:55:02 AM »
Thanks Tweakie
I now looked at the signals with an oscilloscope and pulses do arrive at the MA860H inputs but nothing is going out to the motor when it does not work.  Just strange that moving the X axis temporarily fixes the Y axis.  I suspect there is something wrong with the signal levels.  Maybe the ground connections are not right.  Will keep investigating.
Re: G1 Y... commands sometimes ignored
« Reply #3 on: May 15, 2017, 01:07:14 PM »
After some investigation I believe the breakout board output pins P4 and P5 are damaged - the low pulses only go to 1V and not zero.  I eventually changed the Y channel to be driven by P6 and P7 and it works fine.  I will change to P16 and P17 after rewiring and reconfiguring.