Hello Guest it is March 08, 2021, 05:15:25 AM

Author Topic: Auto Zero Z-axis Metric  (Read 7472 times)

0 Members and 1 Guest are viewing this topic.

Auto Zero Z-axis Metric
« on: May 11, 2017, 05:17:41 AM »
Hi there,

I have read a ziljon scripts and i still do not understand a thing about them. I am dyslectic as hell (reading only) and just cannot get the hang of it.

I have a router where the hardware is ready and tested for auto zero the Z-axis. It works with some scripts, just the values are not right.

What i need is ultra simple.

I would like to use the probe to zero the Z only with 50 MM a minute a pause/dwelling of 3 seconds would be great
My probe gage is 19.4 mm thick
when measured i would like to raise the Z axis 10 mm. The DRO should point out 10 mm off course.

No more, no less. Most scripts are so complete/complex so i d not understand the first thing about them

Whatever i do i cannot get it to work. metric/imperial. Axis going down in stead of up, stuff like that.

Any help would be very much appreciated

Kind regards

Fred

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Auto Zero Z-axis Metric
« Reply #1 on: May 11, 2017, 05:37:46 AM »
Hi Fred,

This one is very basic but it should do the job.

Tweakie.
KEEP SAFE !
Re: Auto Zero Z-axis Metric
« Reply #2 on: May 11, 2017, 06:41:49 AM »
I will give it a go in a few minutes, thank you very much

Re: Auto Zero Z-axis Metric
« Reply #3 on: May 11, 2017, 07:05:04 AM »
Hi Tweakie. It works with one last drawback (I guess). After touching the probe it doesn't get up 10 mil, but goes down about 10 Cm. Where do I change that in the file ? or is something else wrong. The router works perfectly in every other perspective.

Thanx in advance

Hi Fred,

This one is very basic but it should do the job.

Tweakie.

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Auto Zero Z-axis Metric
« Reply #4 on: May 11, 2017, 07:19:00 AM »
Hi Fred,

Something else is wrong.  :(

The script says raise the Z axis 10 mm (Code "G0 Z10") so why is it going down ?
If you go into the MDI screen and Zero the Z axis then Input G0 Z10 and press Return does the Z axis raise up 10 mm and the Z axis DRO show +10.0000 ?

Tweakie.
KEEP SAFE !
Re: Auto Zero Z-axis Metric
« Reply #5 on: May 11, 2017, 07:32:27 AM »
Sorry, obviously I was not  clear in my answer.

I copied your text without any changes in Mach 3. I run auto tool zero. it holds a few seconds (dwell is ok) goes down the way it should. very slow, I guess 50 mm/minute. then it makes contact with the probe. (for safety-reasons I do it manually high above the router-bed) Then it goes down quite far, I guess about 10 cm. stops, goes up 10 mm, and the DRO says + 10.0005.

So everything seems ok, besides the bit when it makes contact and should just go up, in stead of lowering the Z before it raises it again

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Auto Zero Z-axis Metric
« Reply #6 on: May 11, 2017, 07:39:42 AM »
Hi Fred.

If you touch your probe to the plate does the Digitize LED on the Diagnostics page illuminate?

Tweakie.
KEEP SAFE !
Re: Auto Zero Z-axis Metric
« Reply #7 on: May 11, 2017, 07:45:42 AM »
Yip, it makes contact, and the "digitize" led lights up

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Auto Zero Z-axis Metric
« Reply #8 on: May 11, 2017, 07:54:24 AM »
Hi Fred,

Try this modified script.

Tweakie.
KEEP SAFE !
Re: Auto Zero Z-axis Metric
« Reply #9 on: May 11, 2017, 08:14:22 AM »
Thank you for your efforts. It is getting better, but not right yet. Z axis goes down... I make contact ( as if probe was touched) z-axis goes down a bout 10 mill. DRO says +10.0005