Author Topic: MAch 3 Input switch issues, no Switch recognition.  (Read 573 times)

0 Members and 1 Guest are viewing this topic.

Offline Proform

  • Holding
  • Posts: 1
    • View Profile
MAch 3 Input switch issues, no Switch recognition.
« on: May 10, 2017, 01:57:56 PM »
Hi, I have been working on this for a week, but to no avail.
This is an older CNC shark 24x24 router system with a xylotex XS 3525/8S-3 ver 2 Breakout box I am resurrecting. 425, 3 axis steppers with self contained router. To my recollection my engineer back in 07 could never get them working either when it was new.
I can do most everything I need to so far, but can't get the diagnostic page to show input LED's.
I have gone to the pin Input page and set up the XYZ home, tried every option, ++, -- etc. auto detect never sees the switches.
I can reverse switch operation on that page and then the LED"S will all light up, but never go out, but the system then alerts me that my switch operation is backwards and will auto correct it for me. Then the LED's are all out and still no input.
I have checked that each switch has 5 volts at the switch and breakout board. They are now wired for normally closed.
I used the same connections it came with Pin 10, pin 11 Pin 12 and I added at pin 15 for the E stop which also has a resistor, also wired NC. All have Pull up resistors at the input on the Breakout board. Other side of switch goes to Vcc neg. The VCC + goes only to one end of all the pull-up resistors, the other end of the resistors go to the terminal strip as does each switch respectively.
The only thing I see wrong so far is the driver test. At first it reads "Pulsing too fast", then grabs the system for a test and shows excellent as it runs the test. Don't know if this is the issue. I do see a few high pulse blips during the test, which I understand should not be so high.
Any ideas out there. I tried a different 25 pin port cabling but no change in status., Win XP Pro, so 32 bit, No other programs deliberately running except for something like Estlcam or control panel now and then.
Port 1 address looks good at 0x378, no port 2 to my knowledge, but tried that any way. I haven't checked the voltage thru the parallel cable yet. Kernel speed set to 25000, pulse freq readout is 24995. On Diagnostics screen Port 1 pins 4567&8 are lit green
I am trying to get my home switches set up, and can probably fake it, but want to eventually make a set-up using input to locate the work piece with aluminum tape and an alligator clip and know this at least requires an input. Not sure if I need anything else.
I don't know how to attach the XML I am using, but have a copy.
Anyone have any ideas??

Offline joeaverage

  • Active Member
  • Posts: 4,756
    • View Profile
Re: MAch 3 Input switch issues, no Switch recognition.
« Reply #1 on: May 11, 2017, 03:03:41 PM »
Hi,
it rather sounds like Mach is not communicating with the BoB.

To start with try to make PC/Mach/PP communicate with the BoB. To do this I suggest assigning pin 2 port 1 as X direction and enable it.
Note you don't need the motors hooked up, in fact better if there're not. With Mach enabled jog X in positive direction and note the voltage
of pin 2 with a multimeter. Now jog X in the negative direction and again measure the voltage at pin 2. If PC/Mach/PP is communicating
with the BoB and the BoB is working then the voltage should be high when jogging in one direction and low in the other.

Can you post a manual for your BoB?

Craig
My wife left with my best friend...
     and I miss him!