Hello Guest it is May 27, 2020, 12:48:54 PM

Author Topic: Problem getting torch to fire - Mach3, Proma TCH, Thermal Dynamics Cutmaster 38  (Read 1286 times)

0 Members and 1 Guest are viewing this topic.

I'm running out of hair to pull out. Just purchased an Eagle Plasma table from a guy that used a Thermal Dynamics Cutmaster 51 so I thought it would be a cinch to hook up my 38 to it. I even got his computer, software license, etc., the whole package.  I've got everything wired up as he did but I can't seem to get the torch to fire off. I'm a newby to CNC so I'm sure I'm missing something simple. I've searched forums, watched Youtube videos, and played around with about every setting I can think of.

When I try to fire the torch with a M3 command on the Diagnostics page, the Output1 block flashes red.

Anyone want to have mercy on a old dog trying to learn new tricks?


Dale Gray
« Last Edit: May 08, 2017, 09:52:29 PM by Alabass »
there will have to be a output assigned to Mach3 to control the plasma.
Go to Config/Ports and Pins/Output Signals and scan thru the list, is there a signal which looks like it may have been used to control
the Cutmaster 51? If so note the port and pin number assigned to the output.

On the diagnostics tab you should now see the output LED go active when M3 is called in a cut program. Sorry, just rereading
your post and it appears Output1 is the signal of interest.
With a multimeter measure the voltage of the pin assigned to  Output1 and it should reflect the status of the Output1 LED.

You may have to use an amplifier or relay attached to that pin to control your plasma. Do you have a manual for the 38?

I repair welding equipment for a living, on leave at the moment, but don't recall a Thermal Dynamics 38 having an input to fire the arc.
In which case you will have to seize control of the torch trigger circuit, I would suggest a set of normally open contacts of a relay. Also
from memory if the torch parts, the retaining cup, nozzle etc are not 'in place' the trigger circuit is disabled. You should not interfere or
disable that feature its a safety precaution to prevent you from electrocution.

My wife left with my best friend...
     and I miss him!
Craig, thanks for the info. He had his setup where Output 1 used Pin 8. The torch for the 51 and 38 are the same so I hooked it up just like his. The service manual for the 51 and the 38 both show 4 wires for going to the torch, two say switch and two say PIP. He had a relay hooked to the two PIP wires. I've tried both sets and neither work. I did find that with the relay wired to my two PIP wires that there was continuity on the wires to the relay while off. when I tried wiring the relay to the "Switch" wires, there was no continuity unless I pulled the trigger. the 38 is supposed to work with a CNC table from what I've read.
4 wires... sounds right. Two wires for PIP.

With all parts in place test for continuity between all 4 wires, there should be continuity between two of them, the PIP wires.
The other two are therefore the trigger wires.

Where the torch attaches to the machine open the cable and cut that pair of wires for the trigger. They can be extended and then
attached to the NO contacts of a relay. Note you cannot directly hook them to pin 8 of your breakout board. The 38 will probably
power one of the wires via a resistor, 1k commonly, with 24V. When the trigger is made the two wires are in effect shorted together allowing
a current, 24mA, to flow which the machine detects as trigger active and starts it pilot arc procedure. To hook that trigger wire to a breakout
board is to invite the 24V source albeit current limited to blow the output of the breakout board.

Instead use a relay, a 5V relay coil if the breakout board is 5V, a 12V coil for a 12V breakout board, etc. One coil contact of the relay will be hooked to
pin 8 and the other to 0V. The relay should now operate (click) with the output pin. The NO contacts can now be soldered to the trigger wires
as they come out of the 38.

My wife left with my best friend...
     and I miss him!
Craig, thanks for all the advice. I finally got it working last night. Jumped the wires at the relay and the torch fired up so I knew then the problem had to be between the relay and the control board from the serial cable. Found there were two ground wires going to the relay instead of a ground and a 5V. Corrected the wiring and it works now.

Now I have to get the Proma Compact THC controller working.