Hello Guest it is November 18, 2019, 02:30:13 PM

Author Topic: E-Stop interrupt without reason  (Read 700 times)

0 Members and 1 Guest are viewing this topic.

E-Stop interrupt without reason
« on: May 08, 2017, 03:22:33 AM »
Hi@all

I use Mach3 since 2007 and get now, with the newest versions strange issues.
Two different Machines, two different systems (XP and Win7 x86), two different computers.

Hardware is ESS and Langenfeld-Interface at both machines.

Mach3 interrupt itself with an E-Stop without Hardware-activation, wirering issue or software-activation (no input to see on diagnostics).
Sometimes need many reset-push to get the machine running again, some days runs without any matters, on days like today mach3 hangs-up totally (newest update brings no change).

What else could make an unseeable E-stop-activation?

best regards

Offline Tweakie.CNC

*
  • *
  •  8,002 8,002
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: E-Stop interrupt without reason
« Reply #1 on: May 08, 2017, 03:58:01 AM »
Generally the problem is caused by electrical noise or it could be caused by bad EStop / limit / home switches.

Try lightly tapping the switches with a screwdriver handle and see if this triggers the Estop condition.

The electrical noise immunity is set within the ESS config. so follow the Warp9 setup guide for the optimum settings. If this makes a difference then you need to investigate and tackle the source of the electrical noise.

Hope this helps.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: E-Stop interrupt without reason
« Reply #2 on: May 08, 2017, 04:39:54 AM »
Thanks Tweakie

As i wrote before, there is no external or internal trigger on the inputs to see in the diagnostics.
It happens not each time but sometimes its a big issue. Actually it runs well again.
Tooks me nearly 1 hour to get it running again, appears at automatic-run, manual-jog and still at reference-drive.
I still tried to switchoff the watchdog of mach3 and the E-stop i set to LPT2 without any function. Still a deactvating of all input-pins wont change this issue.
AC-Filter is inside both controllers.
For me absolutly strange how the same issue happens on two different systems, machines and controllers.
Electrical noise could be a reason here in China ^^