Hello Guest it is May 28, 2024, 04:16:25 PM

Author Topic: steppers are acting strange  (Read 1657 times)

0 Members and 1 Guest are viewing this topic.

steppers are acting strange
« on: May 03, 2017, 01:05:35 PM »
Hi there
 I have two steppers for my Y axis, and it was working almost Ok, I had only occasional stalls.
I decided to change my gear on the steppers, so I replaced the 13 pitch or tooth Gear(pinion), with a 22 Pitch or tooth.

I am using 1600 per revolution for my resolution, and 22 tooth * by the 7 mm .    22*7=154 mm, Then I divide the 1600/154= 10.38
 I entered this  value for the step per unit. I get almost no movement, I tried the value of 90, with a very low speed of about 2000 mm and acceleration of 50. I get my best result, and it moves much much faster than 2000 mm/min. and it stops after few seconds of me relaxing the up or down arrow.
I should mention that for few hours, I tried all different kind of scenarios, But with out any real success, I just could not figure out its behavior.

Does any one have any explanation or recommendation for me?

Could it be that I have a lose connected wire? How can I check for my wiring? needless to say That all my wires are in E chain.

What is the best way to find out the best speed and acceleration for my machine? Knowing that motor tuning is not working properly For me at the time.

Also whenever it stalls it spears that the motor is not sitting properly on the Rack, It looks kind of lose. But when it is moving it appears that it is Ok. Is this a Normal behavior?

« Last Edit: May 03, 2017, 01:09:22 PM by Johnansaro »
Re: steppers are acting strange
« Reply #1 on: May 09, 2017, 07:08:06 PM »
I'm trying to imagine the situation you're describing. I guess you have a 22 tooth pulley on the motor shaft and a 7mm pitch timing belt
around the pulley and anchored under tension at each end of the axis?

If that's the case then your calculation looks about right yet its not from what you've described.

Just to confirm go to Config/Select Native Units and check that the units are mm. There is a warning not to use this setting if you wish just
to cut a job with an inch program, there is a better way to do that. In fact once you've set the native units you should never have to go
back there.
'I enjoy sex at 73.....I live at 71 so its not too far to walk.'
Re: steppers are acting strange
« Reply #2 on: May 09, 2017, 07:19:57 PM »
what stepper drivers are you using? It sounds like they are not microstepping in the way you think they should.

May I suggest as an experiment to set the drivers to full step and see if you can make the calculation and the reality
match. Thereafter you will be able to change say the microstepping and have a feel if its working correctly.

If you set the driver to full step then 200 pluses will secure one revolution of the stepper. If the axis moves 154 mm per
revolution of the stepper then set the steps per to 1.2987. Leave max speed at 2000mm/min accel 50 and try MDIing.

'I enjoy sex at 73.....I live at 71 so its not too far to walk.'