Hello Guest it is April 18, 2019, 07:23:36 AM

Author Topic: Speed control of spindle through my bob  (Read 1156 times)

0 Members and 1 Guest are viewing this topic.

Speed control of spindle through my bob
« on: April 28, 2017, 04:26:31 AM »
Hi There
First of I would like to Congratulate the Mach3 people for their most wonderful software also thank this forum, for giving me the opportunity of placing my question here.
I need help on the issue of controlling the speed of my Spindle through my Bob.
I am putting together a wood cutting 3 axis CNC Machine.
I am using a typical so called 5 axis Popular Chinese Bob of which, I am attaching a supporting Docs.
Also I am using a 3 Hp., LS Inverter,  Plus a Single phase 3 Hp Spindle of which I am also attaching the supporting docs.
Also I am using Mach3 Version R3.041.
Finally a 24 VDC 20 amp Power supply.
I managed to run My step Motors, Emergency Switches and limit switches …, and all is fine, I can also stop and Run my spindle through the Bob.
But I just cannot control the speed of it. Any recommendation is greatly appreciated.
I think I am doing something wrong in my Mach3 Settings, because the Inverter and bob Connection is very straight forward, and I am attaching the V1 from spindle to the 0-10 Volt of my Bob, and com to Gnd of the Bob(Top Row Terminal Of my Inverter, from the picture), similar to my stop and run(Bottom Row Terminal Of my Inverter).
Regards
johnansaro

Online Tweakie.CNC

*
  • *
  •  7,704 7,704
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Speed control of spindle through my bob
« Reply #1 on: April 28, 2017, 04:33:07 AM »
What make and model is your BoB ?
A link to it may be good.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Speed control of spindle through my bob
« Reply #2 on: April 28, 2017, 04:49:25 AM »
I tried to attach the files, but i was unable.
I am trying to attach the files again, it appears I have problem.

I have attached some files. But I can not see them.I do not know what to do, because the system doesn't allow to attach them again
Re: Speed control of spindle through my bob
« Reply #3 on: April 28, 2017, 04:54:45 AM »
I am trying again

Online Tweakie.CNC

*
  • *
  •  7,704 7,704
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Speed control of spindle through my bob
« Reply #4 on: April 28, 2017, 05:15:03 AM »
My best suggestion is that you follow the instructions provided with your BoB for setting up the spindle (for example, your BoB says use PWM for speed control but you have set Step Dir.).

You should be using a later version of Mach3 (version R3.043.062 is considered best) the version you are using has many out of date features.

(Our quirky forum requires a unique name for every attachment and does not allow second tries).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Speed control of spindle through my bob
« Reply #5 on: May 03, 2017, 12:36:06 PM »
Hi there

Thanks Tweakie.CNC, I followed your advice, and all is fine now, and I have full control of my spindle.

Thanks again.

Online Tweakie.CNC

*
  • *
  •  7,704 7,704
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Speed control of spindle through my bob
« Reply #6 on: May 04, 2017, 01:11:38 AM »
Excellent news  :)

I am pleased you have it sorted.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.