Hello Guest it is September 20, 2021, 10:58:03 PM

Author Topic: Gremlins in Mach3  (Read 1727 times)

0 Members and 1 Guest are viewing this topic.

Gremlins in Mach3
« on: April 01, 2017, 10:10:10 PM »
Hi there, I am using 2010 screen set on home made router, every time I use the simple auto zero, z axis will come down to touch off plate make contact retract and touch off again... some times it will go up to clearance specified.. other times a drop down box will ask if it is ok to retract.. press ok and it will go up... but now instead of going up it will come down to the touch off plate and stay there, is there any thing that can be done?  and to-day after cutting about 20 name plates the screen freezes up but only when you go to close the g code nothing happens the g code is still on the screen.. all the axis can be moved, the dro's show the movement etc, the reset button works. but the screen will not clear or load another g code, only way to clear it is to shut Mach3 down and restart, this only started to-day.  Any info will be greatly appreciated. I have attached my xml file

Regards
Nick

Offline Davek0974

*
  •  2,606 2,606
    • View Profile
    • DD Metal Products Ltd
Re: Gremlins in Mach3
« Reply #1 on: April 02, 2017, 03:25:59 AM »
What version are you running?

I think V062 or older maybe 028 is recommended.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.
Re: Gremlins in Mach3
« Reply #2 on: April 02, 2017, 03:38:01 AM »
Hi Daveko974, I am running version .62

Offline Davek0974

*
  •  2,606 2,606
    • View Profile
    • DD Metal Products Ltd
Re: Gremlins in Mach3
« Reply #3 on: April 02, 2017, 07:27:05 AM »
Thats what i'm running and the same screen too.

Is the pc dedicated and cleaned out - no antivirus, network, wifi, music playing, screen savers, power saving, anything at all????
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.

Offline ger21

*
  • *
  •  6,292 6,292
    • View Profile
    • The CNC Woodworker
Re: Gremlins in Mach3
« Reply #4 on: April 02, 2017, 05:44:16 PM »
Try replacing the .xml file from one in your .xml backups folder, from a date when it was working correctly. (You need to rename the extension)
If that doesn't help, all you can really do is uninstall Mach3 completely, and re-install.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Gremlins in Mach3
« Reply #5 on: April 03, 2017, 07:26:42 AM »
Thanks for your replies gentlemen, swapping the .xml file half solved the problem...... but I think a re-load of Mach3 may be in order.

Regards
Nick

Offline ger21

*
  • *
  •  6,292 6,292
    • View Profile
    • The CNC Woodworker
Re: Gremlins in Mach3
« Reply #6 on: April 03, 2017, 07:37:53 AM »
When it's back to working normally, make a copy of the good .xml and keep it safe somewhere.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html