Hello Guest it is May 31, 2020, 02:36:57 AM

Author Topic: Autodesk > LazyCam > Gcode > Mach3 Plasma Circles are not cutting right  (Read 1623 times)

0 Members and 1 Guest are viewing this topic.



Hello everyone!
I hope you all can help me out with a setup I have going on.

How I go about creating my circle via Autodesk AutoCAD 2017
I draw a circle 60.125"
Save as "AutoCAD R12/LT2 DXF(*dxf)"
Launch LazyCAM and open said file (*dxf)
I see the circle on my screen and process it to create the GCODE
launch MACH3 and upload Gcode
run a test and see that at 12-6o'clock and 9-3oclock is cutting straight instead of a curve like a circle should have...
anyone have any experience with this problem and a solution?

Regards,
Fernando

Offline RICH

*
  • *
  •  7,409 7,409
    • View Profile
Post the file done in ACAD 2017.
Post the dxf file you created.

I assume you are using the Plasma module in Lazycam and you will need the pro version to generate code
for any module other than mill. Make sure that you set the Plasma Post Options.
Steps for plasma:
1.   Create a dxf and open in  LC .
2.   Select the Plasma Module
3.   Click Setup and on the bottom right you will see Plasma Options.
4.   Click the Plasma Options button so you can define your plasma settings. Click OK button
        when done.
5.   Select what you want to cut.
6.   Click the Post Code button

RICH


Offline RICH

*
  • *
  •  7,409 7,409
    • View Profile
BTW,
LC will post good code for plasma but you also need an appropriate M3 macro for your machine setup.
I don't have a plasma machine, but, what I posted is based on what worked for a friends machine.
There is a manual for LC in Members Doc's and hopefully you had a read of it. The plasma module is not cover in the manual but just use what I posted and you should get proper code all things considered.

RICH
attached is the dxf file

greatly appreciated the help !

Offline RICH

*
  • *
  •  7,409 7,409
    • View Profile
The reason you are getting those lines at 12 & 6 o'clock are because they are part of your drawing.
You can turn off / manipulate layers in LC so they won't be part of the post.
I would recommend that you draw things on different layers  in cad to begin with.
All this is covered in the manual, READ IT.

Also read about lead in / outs as you may want them and define the plasma options for your machine in LC.

RICH