Hello Guest it is June 01, 2023, 09:06:28 PM

Author Topic: Pokeys57cnc lost motion  (Read 2269 times)

0 Members and 1 Guest are viewing this topic.

Pokeys57cnc lost motion
« on: March 29, 2017, 02:58:14 PM »
I was set up using Pokeys with Mach3 and all was working ok except I have been dealing with problems with the index pulse. That aside I closed out of mach at the end of the day and powered down the mill and Pokeys. When I came in in the morning I started the computer then powered the mill and started Mach3 and I had no plugin? I had to go to the configuration tab and re check pokeys plugin, close out and restart But still no plugin. I am hooked up via Ethernet and went to the control panel and checked the properties tab for the Ethernet connection and found the IP address I had assigned was gone and it was set to auto. I changed it back to the assigned address and then rebooted the computer. After reboot I now have pokeys showing up in Mach but I have lost all motion. I hit the home switches while in the diagnosics tab and they light up but I can not jog or move in MDI. The DRO's respond but I have no movement.

Can someone help me out here? It seems every time I try to solve one problem a new one starts before I can correct the one I am working on. This is my first buid with Pokeys and it is not going well!

Thanks for any input,

Re: Pokeys57cnc lost motion
« Reply #1 on: March 29, 2017, 03:23:52 PM »
I noticed that the status light for the pokeys board blinks as it should when you start the Pokeys software outside of Mach? When you open Mach there is no status light.

I tried replacing the XML with one from a few days ago that was working and that did not work. I then went to function config tab and hit reset device selection. I closed out of Mach and restarted it and it asked if I wanted to use Pokeys external engine I said yes and still no status light ???

Please help I am out of ideas,


Offline NeoTO

  •  504 504
    • View Profile
    • PoLabs
Re: Pokeys57cnc lost motion
« Reply #2 on: May 19, 2017, 01:15:10 AM »
1. Never use PoKeys software if Mach4 is running. You can inadvertedly change settings of the device that can make the device operate incorrectly in Mach4...
2. Check that you have the latest Mach4 plugin ( and the PoKeys firrmware (4.2.32)
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope