Hello Guest it is September 21, 2019, 02:24:56 AM

Author Topic: G28 command causes "Soft limit exceeded" message.  (Read 1294 times)

0 Members and 1 Guest are viewing this topic.

Offline Zaae

*
  •  115 115
    • View Profile
G28 command causes "Soft limit exceeded" message.
« on: March 21, 2017, 04:44:33 PM »
Hello all,

On my 3 axis mill, I have home switches on X, Y and Z.

Soft limits have been configured, and appear to work as expected. The problem comes when the program runs the G28 command.

After homing all axes to zero, (Z zero is home, downward travel is negative) using G28 causes "Soft limit exceeded" to appear in the status box on the main screen, after the Z axis gets to the home position. No soft limit popup box appears when starting the program, and the Z did not trigger the home switch.  Once this happens, the code will not continue. I get the error even with the home switch disconnected.

I can run the same program with soft limits disabled, and it will run just fine.

I can duplicate the problem by homing, jogging away from the home switches, and running a G28 in the MDI screen.

Any thoughts on this? I've done hours of research, but haven't found a solution.

Thanks,
Z
Re: G28 command causes "Soft limit exceeded" message.
« Reply #1 on: March 25, 2017, 11:27:18 PM »
Hi,
sounds bizarre. The only thing I can think of is on Config/Homing-Limits page there is a panel where you can
set the co-ords for your G28 location. Could the G28 Z axis location be outside you soft limit area?

If memory serves G28 doesn't go directly to its assigned location, it goes via an intermediate location usually
selected so the tool is clear of clamps etc. If that intermediate location is not specified the current location
is assumed. Presumably the current location is within the soft limits and so shouldn't affect things but its how
Mach operates internally and may be giving you grief.

Craig

My wife left with my best friend...
     and I miss him!

Offline Zaae

*
  •  115 115
    • View Profile
Re: G28 command causes "Soft limit exceeded" message.
« Reply #2 on: March 26, 2017, 01:51:39 PM »
Craig,

Thanks very much for the response. I had convinced myself that all of the locations for the G28 being zero was not the problem, but I took your advice, tried some other numbers in there, and yes, the program will run now! Now I can keep working on the other 75 issues I have to solve. :)

Thanks!
Z
Re: G28 command causes "Soft limit exceeded" message.
« Reply #3 on: March 27, 2017, 02:21:27 AM »
Hi Z,
I am intrigued, my G28 co-ords are, or rather were, set to 0,0,0 when I last used Mach3 and it seemed to work.
Are you saying that if one or more co-ords are zero the machine bombs?

Could it be that if your soft limit is 0,0,0 and it triggers when you call G28 when set to 0,0,0? You might try setting your
soft limits -.001,-.001,-.001 and try again. Hopefully the soft limits won't trigger given that your G28 'home' is just
marginally inside your limits.

Craig
My wife left with my best friend...
     and I miss him!

Offline Zaae

*
  •  115 115
    • View Profile
Re: G28 command causes "Soft limit exceeded" message.
« Reply #4 on: March 30, 2017, 05:48:14 PM »
Craig,

That could work, but I haven't had the time, or need to mess with them since you helped me solve the problem. Right now, I have G28 set in a more comfortable location for tool changes.

Thanks again :)

Z