Hello Guest it is May 13, 2021, 05:25:58 PM

Author Topic: Threading cutting Tool path running incorrectly in Mach3 turn Version R3.043.066  (Read 3428 times)

0 Members and 1 Guest are viewing this topic.

I am running Mach3  turn  Version R3.043.066 everything works okay when I use a wizard or fusion 360 to generate a tool path the part turns out fine, but when I try to use the wizard or fusion 360 to create a thread it shows the tool path in the software and it looks fine, but when you hit run it moves down to the part waits for the indexing signal runs down the first path okay then retracts and moves about three quarters of the way back down the tool path then moves in to the part goes all the way back to Z0 cutting thread backwards then starts back down the tool path the end result is the last part of the thread is fine but where it drops back in on the way back is ruined because it is effectively cutting backwards as well as forwards I have tried everything that I can think of, looked at the forums but can't seem to find an answer your help would be much appreciated.  I have attached some photos of the  tool path before I run it and after I  run it and this is the code that is generated

G0 G40 G18 G80 G50 G90
G00 G53 X0 Z0
G00  X12
G00 Z5
G00 X9
M03 S300
G76 X7.12 Z-30 Q1 P0.5 J0.006 L0 H0.4 I0 C3 B0.0001 T0
« Last Edit: March 21, 2017, 02:59:28 AM by Mgray »

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
I would suggest you use version  R3.043.062 as 066 is buggy.

This is the code that fusion 360 generates a thought this might help but as I said earlier it doesn't matter whether I use the wizard or fusion 360 the end result is the same

O1001 (MOUNT)
N10 G90 G95 G18
N11 G21
N12 G28 U0.

N13 T0100
N14 G54
N15 M8
N16 G94
N17 G97 S300 M3
N18 G0 X29. Z5.
N19 G1 X8.92 F1000.
N20 G32 Z-30. F1.
N21 X10.6 F1.
N22 G0 X29.
N23 Z5.
N24 G1 X8.84 F1000.
N25 G32 Z-30. F1.
N26 X10.6 F1.
N27 G0 X29.
N28 Z5.
N29 G1 X8.76 F1000.
N30 G32 Z-30. F1.
N31 X10.6 F1.
N32 G0 X29.
N33 Z5.
N34 G1 X8.68 F1000.
N35 G32 Z-30. F1.
N36 X10.6 F1.
N37 G0 X29.
N38 Z5.
N39 G1 X8.6 F1000.
N40 G32 Z-30. F1.
N41 X10.6 F1.
N42 G0 X29.
N43 Z5.
N44 G1 X8.52 F1000.
N45 G32 Z-30. F1.
N46 X10.6 F1.
N47 G0 X29.
N48 Z5.
N49 G1 X8.44 F1000.
N50 G32 Z-30. F1.
N51 X10.6 F1.
N52 G0 X29.
N53 Z5.
N54 G1 X8.36 F1000.
N55 G32 Z-30. F1.
N56 X10.6 F1.
N57 G0 X29.
N58 Z5.
N59 G1 X8.28 F1000.
N60 G32 Z-30. F1.
N61 X10.6 F1.
N62 G0 X29.
N63 Z5.
N64 G1 X8.2 F1000.
N65 G32 Z-30. F1.
N66 X10.6 F1.
N67 G0 X29.
N68 Z5.
N69 G1 X8.12 F1000.
N70 G32 Z-30. F1.
N71 X10.6 F1.
N72 G0 X29.
N73 Z5.
N74 G1 X8.04 F1000.
N75 G32 Z-30. F1.
N76 X10.6 F1.
N77 G0 X29.
N78 Z5.
N79 G1 X7.96 F1000.
N80 G32 Z-30. F1.
N81 X10.6 F1.
N82 G0 X29.
N83 Z5.
N84 G1 X7.88 F1000.
N85 G32 Z-30. F1.
N86 X10.6 F1.
N87 G0 X29.
N88 Z5.
N89 G1 X7.8 F1000.
N90 G32 Z-30. F1.
N91 X10.6 F1.
N92 G0 X29.
N93 Z5.
N94 G1 X7.72 F1000.
N95 G32 Z-30. F1.
N96 X10.6 F1.
N97 G0 X29.
N98 Z5.
N99 G1 X7.64 F1000.
N100 G32 Z-30. F1.
N101 X10.6 F1.
N102 G0 X29.
N103 Z5.
N104 G1 X7.56 F1000.
N105 G32 Z-30. F1.
N106 X10.6 F1.
N107 G0 X29.
N108 Z5.
N109 G1 X7.48 F1000.
N110 G32 Z-30. F1.
N111 X10.6 F1.
N112 G0 X29.
N113 Z5.
N114 G1 X7.4 F1000.
N115 G32 Z-30. F1.
N116 X10.6 F1.
N117 G0 X29.
N118 Z5.
N119 G1 X7.4 F1000.
N120 G32 Z-30. F1.
N121 X10.6 F1.
N122 G0 X29.
N123 Z5.

N124 M9
N125 G28 U0. W0.
N126 M30

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
What post processor are you using in Fusion for the lathe?
Code is ok and looks like the Fanuc pp is being used. ( note the G28 code and use of U & W )
Do you have work offset values for G54 in Mach?

Try version .062.

Hi Rich Thanks for the reply this may sound like a strange question but as I have only recently got  my version of Mach3  I went to  the website  and  only the latest version   seemed to be available for download
 regards Mark

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
In the Artsoft site:

On left side of page:
Software & Downloads> Downloads & Updates
click the FTP Downloads tab
click FTP Server - Main Menu
Click Directory Mach3

Now you will see the different versions available for download

Thanks so much for all your help Rich  as soon as I get time probably this weekend I will download it and keep you informed
 thanks again regards Mark

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
You may want to download the version revisions list.
Users  have said 066 has is problematic and I have never bothered using it and all current work I do is with .062.
Relative to Fusion 360 Lathe, I modified the Mach3 post processor to get rid of some of the start and end posted code and few other commands.
It all depends on how a user is setting up for the work and their configuration. G28 & G31  may not behave as one expects and as described in
the manual.

Fusion 360 lathe is rather nice , but there is a learning curve to it.

Hi Rich I loaded version .062    ran it with the wizard  and fusion 360 same result as version .066  I was wondering whether you would be able to send me a copy of the post  processor you are using with fusion 360
 and a couple of simple threading programs that way I could load it into my machine and  see if it works on mine  I have sent a  email to Artsoft  they suggested that I load mach4  with a PMDX smart bobs  orpokey57CNCd25  motion controller  as they seem to think Mach3  had its limitations with threading.
 I will do that if I have to but at the moment my lathe   can be run in manual mode using Arduino  and encoder wheels which is being  control through a GECKO 540  parallel port  controller  using a port switch  so if I upgrade to ethernet I would need to use something that I could plug my encoders into  so I can run the lathe manually  I was thinking of using a Vital  motion controller,   I will go down this path if I can't get it working on Mach3
 regards Mark

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
I use Mach3 version 062,with  a parallel port, and threading works just fine. I have the G76 set so that it posts G32 with comments.
I like to monitor the threading cycles as they are being done.
See page 47 in Threading  On The Lathe - Mach3 Turn on how to modify the Macro M1076 if  you desire to G32 output of the code.

Not sure what your lathe setup is and that may be your problem and why they recommended what they did.

Not sure what Fusion post processor you are using. You can download one called mach3 turning.cps from the Autodesk site.
Here is a link :  

I don't want to want to post the modified post processor since it's modified to work with the way I work and you may desire some of the posting that the generic one posts.

Your posted code runs fine here and note that the G28 ( see attached )will cut  through the material.


« Last Edit: March 26, 2017, 10:12:04 AM by RICH »