Hello Guest it is October 18, 2019, 10:51:56 PM

Author Topic: Setting Limit switches  (Read 3362 times)

0 Members and 1 Guest are viewing this topic.

Offline bodger_roger

*
  •  7 7
  • Roger, Always an engineer!!
    • View Profile
    • foundry-fopars
Setting Limit switches
« on: June 17, 2007, 03:41:00 PM »
www.foundry-fopars.co.uk

Right I am new to both cnc and mach, i have been building my machine from scratch and casting aluminium bits for some time now, eventualy i come to the electronics.
Last weekend i wired and successfully linked each linit switch Home and Limit+ to a pin on the printer port, and as i clicked a switch i could see the lights change.
now this week end having got some motors runing i can nolonger see the port activity when i click a limit or home switch.

Question what would stop the diagnostics screen from displaying the pin activity,  the most obvious is that i set somthing unknowingly but what.

Any help!!!!!!!

if you would like to see my creation click on the link above and navigate to the CNC link you will see the build unfold.

Thanks

Roger
« Last Edit: June 18, 2007, 03:31:52 PM by bodger_roger »

Hood

*
Re: Setting Limit switches
« Reply #1 on: June 23, 2007, 02:59:33 PM »
Roger if you could attach the xml we can have a look and see if you have done anything obvious. You will find the xml in the Mach3 folder, if you are using the standard Mach3Mill profile it will be called Mach3Mill.xml. You will need to copy it (to desktop for instance) and rename it before you can attach it. To attach it to your reply use the full reply page. If you get stuck have a look at Bretts (chaoticones) tutor post at the top of the forum.

Hood

Offline bodger_roger

*
  •  7 7
  • Roger, Always an engineer!!
    • View Profile
    • foundry-fopars
Re: Setting Limit switches
« Reply #2 on: June 23, 2007, 06:38:50 PM »
Hi HOOD!!

Thanks for the reply,
Things have moved on a lot since my last post, i have found that uninstalling windows sp2 regaind control over the limit switches to the extent that i could see the lights on the diagnostic page and run g-code ( road runner ) however i noticed that as i swoped from one program to another playing with the machine ( as one does )i was loosing control over funtions that i could give. foe example i lost input on the numeric section of the keypad so that i could not change the values oth position.
This has made me think that there must be somthing fundimentaly wrong with my pc even though it seems to work well with other progerames.

so this has led to the next question, how many people out there have had simular problems or is it my cranky pc, afterall it is a 1GHz P3 it should work fine, but somthing is wromg...

Roger

Hood

*
Re: Setting Limit switches
« Reply #3 on: June 24, 2007, 02:40:37 AM »
Sounds like your windows install is corrupt, you say you uninstalled SP2, but how did you do that? ie did you format the drive and put on a clean install of windows or just use the add remove programmes to uninstall the service pack?
Hood

Offline bodger_roger

*
  •  7 7
  • Roger, Always an engineer!!
    • View Profile
    • foundry-fopars
Re: Setting Limit switches
« Reply #4 on: June 24, 2007, 04:42:14 AM »
HOOD, Thanks for the reply

Yes i used the add remove funtion to remove the service pack, yes it is quite likly that there are some registrations left in the PC.

I am going for a compleat format and reinstall this morning, with win2k, so watch this space


Roger

Offline bodger_roger

*
  •  7 7
  • Roger, Always an engineer!!
    • View Profile
    • foundry-fopars
Re: Setting Limit switches
« Reply #5 on: June 24, 2007, 02:28:50 PM »
Well that seems to have fixed it,

i formated the drive and reinstalled windows.
now all back to as it was and the machine seems to be preforming as expected.

Thanks for the help everyone...

Roger

Hood

*
Re: Setting Limit switches
« Reply #6 on: June 25, 2007, 01:09:41 PM »
Glad you are sorted.
Hood