Hello Guest it is October 19, 2019, 09:25:14 PM

Author Topic: Help with signals/motors for "Blacktooth" laser cutter  (Read 1256 times)

0 Members and 1 Guest are viewing this topic.

Help with signals/motors for "Blacktooth" laser cutter
« on: March 06, 2017, 03:21:53 PM »
Hello, i am having some intense trouble with signals from the Mach3 program not reaching the Blacktooth laser I've built. The program runs the Gcode, but the motors will not turn and the laser is also not firing. I think it may be a problem with eStop but i'm not positive because I've tried many fixes. This is an independent project for my engineering class and any help is appreciated.
Re: Help with signals/motors for "Blacktooth" laser cutter
« Reply #1 on: March 06, 2017, 03:22:21 PM »
I can provide screenshots and pictures if needed.

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Help with signals/motors for "Blacktooth" laser cutter
« Reply #2 on: March 07, 2017, 01:54:02 AM »
Can you attach your .xml file, that will show us all all your Mach3 settings and give us a better chance of providing an answer to the problem. The file is in your Mach3 folder and it is called <your profile> .xml
Copy and rename it to RobertG.xml then using the reply tab and Additional Options... it can be attached.

Tweakie.

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Help with signals/motors for "Blacktooth" laser cutter
« Reply #3 on: March 07, 2017, 02:09:27 PM »
I have created a folder for the .xml folder and made it public in case of future file sharing.

https://drive.google.com/drive/folders/0B-g6EsAIYV8SVUNmY2NpLVhqZEE?usp=sharing

Thankyou for the fast reply, i hope to hear more from you soon.

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Help with signals/motors for "Blacktooth" laser cutter
« Reply #4 on: March 08, 2017, 02:19:37 AM »
Hi Robert,

Your .xml file runs OK here but you need to check (doublecheck) that you have specified the correct pin numbers for your X and Y axis Step and Direction signals.
For switching your laser (on / off) this article may be of assistance to you : http://hobbycncart.com/publ/cikkek/mach3_temaju_cikkek/switching_a_laser_under_mach_control/8-1-0-29

Which CNC controller are you using (breakout board / Drivers) ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Help with signals/motors for "Blacktooth" laser cutter
« Reply #5 on: March 08, 2017, 02:44:28 PM »
Tweakie,

Thanks again for the quick responses. I have uploaded a photo of the breakout board to the folder, sorry for the low resolution. I have checked on the pins and as far as I can tell it is wired correctly. I have read the article that you sent me and I am making sure all my values are correct. As for the drivers I'm not really sure because the laser cutter was built originally 3 years ago. I will let you know if I make any progress. Thank you for the help.

Robert.

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Help with signals/motors for "Blacktooth" laser cutter
« Reply #6 on: March 09, 2017, 01:55:58 AM »
Hi Robert,

I think you also need to contact Build your CNC and get a wiring diagram from them and any other information they have regarding the Blacktooth (they charge megga bucks for their stuff so they should provide excellent support).

In the meantime I will see if I can dig up any additional information.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.