Hello Guest it is November 17, 2019, 07:25:04 AM

Author Topic: Single block mode  (Read 2297 times)

0 Members and 1 Guest are viewing this topic.

Single block mode
« on: March 01, 2017, 02:04:33 PM »
Can someone tell me if the single block mode in mach4 works? I have tried to use it three times now, and each time it will start but when I hit cycle start to initiate the next line. Nothing happens. The program will not progress to the next line. Is it operator error or does this feature not work?
Re: Single block mode
« Reply #1 on: March 02, 2017, 06:18:22 AM »
?? Any help please?
Re: Single block mode
« Reply #2 on: March 02, 2017, 12:00:37 PM »
You probably aren't getting any response because no one has used it yet.

Using M4 Mill in Sim mode it does appear to work the way you would think.  Press single block, cycle start and it executes that line.  You then have to press single block to turn it off and then again to turn it back on and then cycle start for the next line to execute. 

The Cycle Start button left up event calls the cycleStart() function in the screen start script which calls mcCntlCycleStart() which you can't change.  Someone more adpt at lua than I could probably alter the button event to check if the single block is in effect and enable itself but that is beyond my knowledge.

Seems that the default behavior should be that after the line is executed you should again be able to do another cycle start.  Maybe someone else knows why it was implemented this way.

TIA

RT
Re: Single block mode
« Reply #3 on: March 02, 2017, 04:55:43 PM »
On a real controller you enter single block mode the press cycle start to jump through the lines of code. I just assumed that mach4 would work in a similar fashion. It seems futile to have to hit single block, then cyclestop, then turn off then on single block then cyclestop, then repeat. I really wish mach4 had better documentation as to the functionality and how it works. It seems very counter productive to have to figure out how to operate the control and try to get things accomplished. Yes there are a lot of things that work as they should and expected, but there are also a lot of functionality that appears to be there but is tremendously lacking.

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: Single block mode
« Reply #4 on: March 03, 2017, 03:17:43 AM »
Single block mode works fine in mach4 however the state of the cycle start button is not correct and is disabled in single block mode. open up the screen editor and select the cycle start button, in the properties for the button you will find enabled states and in there you need to put a check in the File Single Block and save and exit the editor. You should now find the button enabled during a single block mode state allowing the function to work correctly.

DazTheGas
Theres always time for a choccy biccy

Offline thosj

*
  •  366 366
    • View Profile
Re: Single block mode
« Reply #5 on: March 03, 2017, 09:51:04 AM »
I'm new to Mach4, I mean really new (but long time Mach3 user where single block works "as expected").  I haven't run a gcode program in Mach4 yet, but I don't get why the "state of the cycle start button" in Single Block needs to be edited by US. Why is that not the normal "state" like it should be? Turn off Single Block after EVERY block, turn it back on, hit cycle start? For every block? Come on!!

I also come from "real controllers" and I used single block and a Feed Rate POT all the time working with programs written by someone else and not wanting to smash up a 1.2 million dollar machine with an errant tool length call!! If the Z is moving in, or down on a vertical, and the Distance to Go says 15" and I'm 4" from the part, I pretty much know the tool length is wrong or the Z Offset is wrong, BEFORE I hit the part with a 50HP spindle running, and at 200 inches a minute. I know Brian said he doesn't use Single Block, but no reason it shouldn't work correctly after 4 years!!! Lots has been said about Mach 4 being "industry standard" and from 40 years of running CNC machines, single block has been "industry standard." Turn it on, hit cycle start, get one block, hit cycle start again, get the next block.

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: Single block mode
« Reply #6 on: March 03, 2017, 10:19:34 AM »
40 years of running CNC machines, single block has been "industry standard." Turn it on, hit cycle start, get one block, hit cycle start again, get the next block.

Try reading the post above yours, that`s exactly how it does work in mach4. The wx4 screen was originally created from forum requests by users of what they would like to see in the controller as opposed to the default wxMach screenset, the screenset is open to anyone to change and modify to their requirements, but from time to time some small things can be overlooked but quickly added for next release as I am sure this will be ;-) or just a 30 second user fix like this one.

DazTheGas
Theres always time for a choccy biccy

Offline thosj

*
  •  366 366
    • View Profile
Re: Single block mode
« Reply #7 on: March 03, 2017, 10:54:07 AM »
I read the post above mine or I wouldn't have known I needed to edit the button.  ;)

I'll STFU as I really don't know what I'm talking about.  :-\
Re: Single block mode
« Reply #8 on: March 09, 2017, 05:08:49 PM »
I have the single block mode problem not working too.  Interestingly, on the Mach3 forum several people responded it was working fine.
I have not tried to edit the screen so I did not change anything.  As was said, it ought to work correctly to start with.
Bertho

Offline thosj

*
  •  366 366
    • View Profile
Re: Single block mode
« Reply #9 on: March 09, 2017, 05:29:35 PM »
Bertho,

It's very easy to change, VERY easy. And once changed it works like we expect, one press of Cycle Start executes one line of code, next press, next line, ad nasuem.

Just follow DaztheGas instructions above. This'll be the easiest screen edit you EVER make, trust me!!! Wait'll you try LUA script  :-\

Not sure what happens if Mach4 gets upgraded, I guess nothing as the screen is the screen and this edit is in the screen.

And I, too, have no clue why this isn't default behavior of Single Block. Daz seems to think it was merely an oversight up there in Maine!!

If you need more help, let us know, maybe I can get a screen capture or two to help, but, again, this is toe-in-the-water with the screen editor.

Tom