Hello Guest it is July 06, 2020, 09:32:19 AM

Author Topic: Mach 3 slows down at each point  (Read 1539 times)

0 Members and 1 Guest are viewing this topic.

Offline Myk3

*
  •  15 15
    • View Profile
Mach 3 slows down at each point
« on: February 27, 2017, 11:22:51 AM »
I have just installed a jtec photonics laser on my machines and everything seems to be working well in some cases.. At first there was a delay with the M3 / M4 and M5 commands to start / stop the laser, I overcame that by using the M11p and M10p commands in the post processor. Now I am having an issue where mach 3 slows down at each point and I am getting over burn since it pauses ever so slightly at those points..

Setup:
Windows 10
Mach 3 R3.043.066
Ethernet SmoothStepper
Xylotex Controller with bob
ESS version ESS_Mach3_160630_u4f1b (when looking for the proper version ESS recommends MACH3 version R3.043.062 so I might install that version and try it)

I have the constant velocity turned on, and only the look ahead set to 200, as per a thread I found searching this issue.

Video of the issue
https://www.youtube.com/watch?v=oj1cRrwStDQ


Anything anyone can think of while I test the other version of Mach3?

EDIT: I just looked at a picture I took last night of the config screen and it looks like the only other CV setting I currently have the "stop CV on angle set to 0 degrees" 
« Last Edit: February 27, 2017, 11:39:13 AM by Myk3 »

Offline Davek0974

*
  •  2,597 2,597
    • View Profile
    • DD Metal Products Ltd
Re: Mach 3 slows down at each point
« Reply #1 on: February 27, 2017, 01:31:05 PM »
Looking at the video, my money icon your G-code curves being compiled of thousands of tiny moves, this stops mach3 making a smooth trajectory.

Not sure on the fix though, maybe a different code source?
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.

Offline Davek0974

*
  •  2,597 2,597
    • View Profile
    • DD Metal Products Ltd
Re: Mach 3 slows down at each point
« Reply #2 on: February 27, 2017, 01:58:09 PM »
Sorry, that should say "My money is on..."

:)
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.
Re: Mach 3 slows down at each point
« Reply #3 on: February 27, 2017, 02:09:53 PM »
Seems like the angle setting of zero has Mach 3 only doing continuous motion if the line segments are actually in a straight line but what you are cutting has gentle curves. So try putting in a small angle 5 or 10 degrees maybe.

Offline Myk3

*
  •  15 15
    • View Profile
Re: Mach 3 slows down at each point
« Reply #4 on: February 27, 2017, 03:14:15 PM »
Looking at the video, my money icon your G-code curves being compiled of thousands of tiny moves, this stops mach3 making a smooth trajectory.

Not sure on the fix though, maybe a different code source?

This was a simple import into aspire and image trace.. The same thing happens with font and anything else i have tried..

Offline Myk3

*
  •  15 15
    • View Profile
Re: Mach 3 slows down at each point
« Reply #5 on: February 27, 2017, 03:14:47 PM »
Seems like the angle setting of zero has Mach 3 only doing continuous motion if the line segments are actually in a straight line but what you are cutting has gentle curves. So try putting in a small angle 5 or 10 degrees maybe.

I will try that and get back to you..

Offline Myk3

*
  •  15 15
    • View Profile
Re: Mach 3 slows down at each point
« Reply #6 on: February 27, 2017, 05:57:37 PM »
So after changing the CV value to 45 and I think the most important thing.. changing the feed rate, really really slow (30ipm) I got a decent burn.

My theory is that since my laser is only 2.8w it cant carve fast. The spots where i had dots (after changing the cv value) was where mach3 was having to slightly pause while changing directions or where the start / stop points meet. This meant those area where getting slightly longer laser time, which meant more burn. I slowed the feed rate down and I can barely see the dots, since everything is getting a somewhat equal amount of burn time..  You can still slightly see the dots, but it is way way better than before.. and there arent as many dots, at the cv value removed the stops on the curves..



Offline Davek0974

*
  •  2,597 2,597
    • View Profile
    • DD Metal Products Ltd
Re: Mach 3 slows down at each point
« Reply #7 on: February 28, 2017, 02:25:59 AM »
The fact it got better when speed was lowered makes me wonder what setting you have for acceleration in X & Y ??

Good thats its better though.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.

Offline Myk3

*
  •  15 15
    • View Profile
Re: Mach 3 slows down at each point
« Reply #8 on: March 01, 2017, 04:51:14 PM »
So even though i got that fixed i now want to get PWM functions to work.. I don't completely understand how PWM is configured, I followed the instructions on the JTEC site to get it configured, but I do not think it is working right.. as when i enter M3 s1 I am still getting a high powered laser.

For some reason I could only upload 4 screenshots.. so i removed them and put everything in google drive and shared them below..

This is all my setting, that i think are required to enable PWM.. Thanks for the help.. Also in its current state the Laser does turn on / off with the M3 / M5 commands from MDI  / gcode, but in gcode i use the M11p and M10p commands to remove the delay..

https://drive.google.com/drive/folders/0B24uz5OgchgLQ0E1T0dla3FPdGM?usp=sharing

EDIT: Instructions from JTEC..

https://jtechphotonics.com/?page_id=1436

EDIT2: maybe i should start a new thread as this is a different issue..


« Last Edit: March 01, 2017, 04:54:13 PM by Myk3 »