Hello Guest it is May 25, 2019, 05:47:12 AM

Author Topic: C10S BOB to HY DIV268N 5a Drivers  (Read 2206 times)

0 Members and 1 Guest are viewing this topic.

C10S BOB to HY DIV268N 5a Drivers
« on: February 26, 2017, 04:11:29 PM »
Hi to all
I am all new to CNC.
My build is:
1/2 " Aluminum Frame, Gantry and Z Axis Unit
1605 ballscrews 1100, 700 and Z 300mm.
Longs motors, NEMA 23 Steppers 472 OZ,
HY DIV268n 5a Drivers
C10S cnc4pc BoB
MW S_400_36  Power Supply 110vac 36v dc
External Power Supply 5v 3000 Ma ouput

Had a Savebase c5 5 axis Chinese BoB that ended up frying after an hour of tests, ordered another and burned that on equally.

Now Purchased a cnc4pc C10S BoB.
My problem is understanding whether I Pull up or Pull down jumpers and what pins go to what on the drivers.
On the Chinese BOB X,Y and Z pins had Pul, Dir, En and N for ground pin outs.
After searching and reading for more than a week on C10S BoB, I am totally lost. Some instructions say o Jump to Ground COM and others Jump to 5v COM pins.
And nowhere can I find how to connect the EN pins
One of my main concerns is connecting correctly the C10s and how to Out Pin Limit switches , Should they be NO or NC circuit.

I understand configuring Pins in Mach3 but ambiguous to Dir Active Low and Step Low.

I am very anxious to have all this setup work properly as it will permit me to share with other CNC'ers many wonderfull hours of passion.

Thank you for all the help anyone can give...
Rick

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #1 on: February 26, 2017, 08:20:56 PM »
Limit switches should be NC however for the rest of your questions you would get faster service from cnc4pc. I used the C10 a few times but the c10S is new
Nicolas
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #2 on: February 27, 2017, 10:14:28 AM »
Hi Kolias

Did go to cnc4pc a few times but got no answer. The only difference I could see in the C10 to C10S are Push pins to secure instead of screws, also apparently the possibility to double outputs by the use of jumpers. So... If you had your card running, I could use your knowledge :)
What I found since yesterday:
EX 1: Jump COM to 5v and Pin 2 to DIR-, Pin 3 to PUL- and COM that is 5v to DIR+ bridged to PUL+, but nothing to the EN's.
EX 2: COM stays Ground  Pin2 to DIR+ Pin3 to PUL+ ,COM to DIR- and PUL-, and differently I found Pin17 to EN+ and GND to EN-.

So maybe my answer is to Example 2 ?  (Really want to make sure I don't fry again!)

Thanks!

Rick

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #3 on: February 27, 2017, 02:16:27 PM »
Sorry Rick, can’t help today very much but sometimes tomorrow I will have a bit more time

I don’t know the HY DIV268n 5a Drivers so the problem may be there. I attach here the connection instructions from the C10 which I assume are the same as the C10S. If cnc4pc can’t help you is perhaps due to your drivers?.

I left all pins on the C10 to their default values and never had a problem (I used 3 of them on 3 different machines). I don’t know if the pins are the same between C10 and C10S but on the C10 the direction jumper should be Outputs (pins 1&2), COM selection jumper should be (pins 2&3), Pullup or pulldown for pins 2-9 jumper should be (pins 1&2), pullup pulldown jumper for pins 10,11,12,13 and 15 jumper should be (pins 1&2).

Also the power LED should be ON indicating the power feed is correct
BTW what is the voltage of your drivers?
Nicolas
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #4 on: February 28, 2017, 11:08:04 AM »
 Hi Kolias
Thank you for your support so far.

I will include a picture of my wiring so far.
I have plugged everything in starting by the parallel cable and followed by the power units together on a main switch.
In Mach3, Pins are 2,4,6 for DIR- X,Y,Z. Pins 3,5,7 for PUL- and COM for PUL- and DIR- also connected Pin17 to EN+ and GND to En-, EStop to Pin10 and 5v.
Note the reset resets ok but no signal.

Connecting, The Card power light is on, The lights are on normal, hand the steppers click and hold.
In Mach3 I get the jogging to operate in the DROs but nothing to motors. Also in the DIAG all pins led are off but the seventh on.
When I unplug the Parallel cable, the Port 1 pins leds 4,5 6,7,8  light.

(The Drivers I believe are powered in 12v) as seen from the power supply. Drivers are set to 3.3 amps.

What a mess.   :-[

Thanks again Kolias

Richard

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #5 on: February 28, 2017, 01:34:04 PM »
Rick keep in mind my electrical skills are very basic and although I use the C10 before your equipment now are different. In addition your picture is 4853kb which is quite unusual (should have been around 100-200kb) and I can’t see anything when I zoom in.

If the motors are not moving I suspect there is something wrong with the drivers or the wiring to the motors. Do you have wiring diagram for your motors? Did you buy the drivers / motors from the same place?

I used to 4030 drivers before from Keling and they have dip switches. If these switches are not set properly, motors will not move. I can’t help you more because the BOB / drivers / motors you are using are not familiar to me

Looks like no one else in this forum chimed in to help you and I suspect because the equipment you have are not well known. Perhaps you may want to try cnczone.com forum in the Electrical section to see if someone else can give you a hand.
Nicolas
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #6 on: February 28, 2017, 02:55:23 PM »
Kolis
Hi Kolias
I understand the situation, nevertheless I appreciate your efforts.

Yes : I purchased the Drivers and breakout card as a kit and made sure they convened for the NEMA23s.
I verified he motor connections and they are A+, A-, B+, B- correct to the driver.....
Last resort I'll Get another chines card,, although it didn't last ,, I was able to get it running.

I'll flag you if I ever succeed with this card..

Thanks

Richard

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #7 on: February 28, 2017, 03:00:09 PM »
I will not buy from China these kind of equipment. The C10 from Keling is quite inexpensive and works well. Are your motors 4.6 or 8 wires?
In any case good luck
Nicolas
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #8 on: March 01, 2017, 11:30:24 AM »
Hi Kolias

My steppers are 4 wire A+A- B+B- and drivers 6 dips 3 for amps 3 for step
Drivers set 3.3amp step 1/8

No I wont re-buy Chinese, 2 burns are enough  :P

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: C10S BOB to HY DIV268N 5a Drivers
« Reply #9 on: March 01, 2017, 01:15:38 PM »
Good choice not to buy Chinese again, cnc is too complicated to relay on Chinese electronics.

Having only 4 wire motors makes it easier for the wiring. Double check the wiring (I assume you use shielded cables to prevent noise)

In one of my cnc I had similar problem with motors been dead and after a call to Keling it was the settings of the dip switches. In addition in another machine I had the limit switches wired as NO (by mistake) and that prevented the motors to start. Never thought the limits will have anything to do with the motors but its worth to check it
Nicolas