Hello Guest it is November 15, 2019, 05:25:11 AM

Author Topic: X axis  (Read 885 times)

0 Members and 1 Guest are viewing this topic.

X axis
« on: February 19, 2017, 03:04:15 PM »
I am running Mach4 lathe using PMDX 410. Servo motor are tuned and motors run good in mach4 z axis knows what 1.0,.100,.010,.001 and .0001 is in MDI and jog mode Z axis dro read correct . X axis knows 1.,.100,.010,.001 and .0001 in jog mode but in MDI you tell it to move an 1.0 it moves .500 the dro shows it moving 1 inches. ball screw are .200 per rev I check both to make sure of that, both are 1000 line encoders. Any ideals what is going on
Thanks
Re: X axis
« Reply #1 on: February 19, 2017, 03:16:38 PM »
Sounds like you are running a lathe in diameter mode, which is normal.

Jog moves always move the axis the amount defined in the jog setup,
but a G-code commanded move would move the amount needed to
change the diameter by the amount specified. When you observe
the move as radius it is half the value specified in diameter mode.

This diameter/2 = radius move conversion affects only the X axis, and
only happens for lathes, and only when set up for diameter mode.
Steve Stallings
www.PMDX.com
For PMDX product support, please use PMDX forum or direct email for quickest response. We do not use this forum as our primary product support site.
Re: X axis
« Reply #2 on: February 19, 2017, 04:29:10 PM »
Thank you I learn something new all the time. As soon as I read your reply I remembered seeing something in the general about diameter mode that was it
Thanks again