Hello Guest it is May 16, 2021, 09:22:10 PM

Author Topic: Default toll path axis view orientation lathe mode  (Read 2180 times)

0 Members and 1 Guest are viewing this topic.

Default toll path axis view orientation lathe mode
« on: January 25, 2017, 02:58:11 PM »
I cannot figure out how to set the default tool path axis orientation in lathe mode so that I can see the x and z axis and when it regens that is the default view.  Right now my default regeneration view is Y and X axis with edge view(single line) of the Z axis. This is absolutely of no value.

Any assistance would be appreciated.

Aruminat

Skill level-low but improving
Age-High  and getting higher

Offline JDG3

*
  •  19 19
    • View Profile
Re: Default toll path axis view orientation lathe mode
« Reply #1 on: January 25, 2017, 04:37:29 PM »
Not sure if this is what you need.
Configurations - General config - Active plane of movement, check XZ
If a gcode is already loaded, you have to unload and reload for it to take affect.
« Last Edit: January 25, 2017, 04:39:28 PM by JDG3 »
Re: Default toll path axis view orientation lathe mode
« Reply #2 on: January 25, 2017, 06:14:52 PM »
Thank you.  I had that correct but since then I have found that the screen set file was corrupted . What I was seeing on the screen looked like a generic lathe turn screen but it was actually just the screen view of a lathe profile but had the parameters of a mill profile. So while it looked like a lathe tool path and the DRO axis' were labeled X and Z it was showing the X and Y view like a mill tool path when running. The tip off was that in the Config  Ports and Pins menu the right most Turn Options tab was missing. When I found and loaded a lathe profile my view is under control.  In the Mach3 Loader Session Profile screen the Mach3 Turn profile is not a lathe profile it is a mill profile in my system. I will have to do some clean up in there and rebuild my lathe profile and delete the corrupted ones.

A new issue has cropped up.  The X and the Z AXIS dro labels are reversed.  When a G01 X move is initiated the Z AXIS dro changes.  During a Z axis move the X axis dro increments. The machine actually is moving properly according to the g-code, but the AXIS' are reversed.  It seems that the screen labels are wrong. That really messed up my mind when trying  to set home and part zeroes. 
Where might that be edited and corrected?

Aruminat

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Default toll path axis view orientation lathe mode
« Reply #3 on: January 25, 2017, 09:44:07 PM »
Suggest you use version 3.043.062 and not 3.043.066.

Post your xml file ( Current Profile )that you are currently using for the lathe. I will assume that you used the Mach3Turn profile to configure your lathe.You will find the profile in the Mach3 directory on your computer and the
name will be Mach3Turn.xml.

Copy and rename the copied xml to M3TurnAr.xml so the file is unique
and post it.

RICH
Re: Default toll path axis view orientation lathe mode
« Reply #4 on: January 28, 2017, 02:10:56 PM »
Thanks Rich,
Out of town a couple of days helping 2 young entrepreneur friends doing way too heavy construction work for my ancient body, but the payback in the gleam in their eyes makes it worth it.

I will attach  the xml file. I will look for and reload the 0.062 version.  I don't understand where in the program the axis' moves are generated and when that information is fed to the on screen DRO and outputs.  I can switch the output lines to make the machine follow the correct axis moves and I can move the screen labels as a work around, but my nature is to understand and correct what I messed up.  If I knew where to look in the XML I would  but at this point in the game I want to get it running properly, then use this as a lesson on better understanding how the program works and where to "consider" changes to the XML code to tweak things.
With this same issue I have at times opened some XML version where the default tool path view was looking at the edge of the X plane. I am pretty sure I have a lathe XML loaded as well as a lathe screen. I will work on this a bit more before attaching a copy of that.  Is there anything simple should look at first.  Attached also is a screen shot of the attached renamed file.  It shows a 3D rendered piece of material. Where is that coming from and what is defining its dimensions.  It doesn't update to the machined path. it is like the views from the conversational turning profiles.

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Default toll path axis view orientation lathe mode
« Reply #5 on: January 29, 2017, 06:59:14 AM »
Aruminat,

You are not using the 1024.lset for the lathe. The screen set you are using is Glathe.lset  so can't help you.
Believe your problems are in your modified screen set that you are using.

RICH