Hello Guest it is December 06, 2019, 05:25:24 AM

Author Topic: Mach 3 producing very strange unpredictable output  (Read 1030 times)

0 Members and 1 Guest are viewing this topic.

Mach 3 producing very strange unpredictable output
« on: January 22, 2017, 09:06:31 PM »
I am running Version Mach 3 version R3.043.022 on a Win7 box.
My setup has always functioned correctly.
I have not used it in over a year.
Today I fired it up to do a simple cutting job and found that when I load the G-Code the image it is going to process looks nothing like it does in CamBam or SheetCam.
I thought my current file had some bad parameters in it BUT then I opened old G-Code project files and they looked just as bad.
I know the older G-Code files were good and were used on previous jobs.
The images seem to resemble stairs. Very strange.

The Win7 PC is dedicated to running Mach3. It has not been turned on since I last used the mill so nothing could have changed in the PC.

Any suggestions?


Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
Re: Mach 3 producing very strange unpredictable output
« Reply #1 on: January 22, 2017, 10:32:11 PM »
Pictures would help, as I've never heard of anything like what you're describing, and can't really picture it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Mach 3 producing very strange unpredictable output
« Reply #2 on: January 23, 2017, 12:49:47 PM »
I think I found a solution.
I pulled up my plasma torch setup for this machine and opening the same gcode files renders good preview images. I went back to the milling profile and bad previews. That led me to believe something was corrupt in my XML file. I thought I had a backup but as I was searching I found the automatic backups that Mach makes. I grabbed one of those from a few months back and surprise, it works.