Hello Guest it is November 22, 2019, 07:54:36 AM

Author Topic: Version 2 has no tenths jog increment  (Read 2994 times)

0 Members and 1 Guest are viewing this topic.

Re: Version 2 has no tenths jog increment
« Reply #10 on: February 25, 2017, 10:35:30 PM »
I say there is definitely an issue with the tenths jog increment on version 4.2.3233.
 
I've been using the early version 4.2.3206
I decided to add a tab page on the operations tab menu & downloaded the script that Brian Barker offered to make the mouse a MPG.
It worked beautiful for the tenths jog so, I thought I'd use that & run the 3233 version. It didn't work very well on the tenth's increment.
I went back to running version 3206 & it works fine.

 The 3206 works  pretty good except for an occasional slow jog run away that I hope
 I corrected with a script edit I seen on a You Tube video by Daz The Gas (Thanks).

Thank you Mauri for your input. One day I hope to run with the big boys on some professional equipment.
I'm self teaching myself on a Sieg X2 that I built taking baby steps into CNC. I do have a manual Bridgeport if I have to do some
real milling.

Well, that's what I think. Maybe it's just me with that problem or there might be something that the Mach 4 script writers might want to look into.

Thanks
« Last Edit: February 25, 2017, 10:37:26 PM by Todd774 »

Offline Chaoticone

*
  • *
  •  5,630 5,630
  • Precision Chaos
    • View Profile
Re: Version 2 has no tenths jog increment
« Reply #11 on: February 28, 2017, 09:13:13 AM »
OK, I have a little info that may help.

I was wrong here.
If you have 10,000 steps per you should be able to move in .0001 increments with no problem.

I can repeat the problem here too so I think there is something to it. Will let you know what we find.
You must have a higher resolution than the step your trying to make. So to step in .0001 increments you must have steps per > 10,000 in motor tuning for that axis.

I think the reason your seeing differences in the older version and 3233 is because the default profiles were updated in 3233 or earlier but after the version it seemingly works like you want. Check your steps per for whatever axis your testing in both versions and I think you will confirm my hunch.  
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Version 2 has no tenths jog increment
« Reply #12 on: March 05, 2017, 01:21:39 PM »
  Thanks for the reply Chaoticone.
 I just noticed you responded. Thank you.
I just double checked my steps per unit in Mach configuration. 10,000 Steps per unit. on all 3 of my motors  0,1,2    X,Y,Z
My motors are 200 step per rotation
My Gecko 540 is supposedly 10 microsteps fixed (so I am under the impression of)
My lead screw is 5 TPI (Inches)
So 200 * 10 * 5 = 10,000.
so that should give me 10,000 steps per inch or 1 microstep should be .0001
Does that sound right?
I didn't see any other adjustments for steps in my PMDX plug-in. (just so I don't over look anything here)
Am I on the same page as you?  I'm a little green remember.
Thanks again
 Todd K.
Re: Version 2 has no tenths jog increment
« Reply #13 on: March 05, 2017, 01:55:11 PM »
Just to make sure that I wasn't over looking things, I downloaded 3233 again & made sure the steps per unit didn't change.
While I was at it, I checked the tenths jog increment (No Go).
Then I tried the tenths increment on the mouse MPG (works on the roller of the mouse).
If I whip it really fast, it jumps 4 or 6 tenths.
I put it back to 3206 & the tenths work just fine. even the mouse MPG works sweet.
If I set it to .00001 I get 1 tenth at a time just gently rolling the mouse wheel.