Hello Guest it is October 20, 2019, 09:03:32 PM

Author Topic: Sorry to be a pain again but  (Read 2566 times)

0 Members and 1 Guest are viewing this topic.

Sorry to be a pain again but
« on: January 08, 2017, 09:30:28 AM »
I have sorted a g code out that works in simulation . No problem teither however when I turn my 3040 cnc on to engrave the cò
It follows the path but z axis doesn't drop down engrave the wood.  I know it's just a setting probably but not sure if it's in artcam or mach 3? If I manually lower z axis to wood it raises back up to original position .  Thanks in advance for all suggestions
Re: Sorry to be a pain again but
« Reply #1 on: January 08, 2017, 10:17:57 AM »
Cold be several things, maybe you have not set the pins for the Z axis, does it move when you jog it?  Have you a Z code in the program to lower the tool into the material eg G00 Z-1 which is rapid down of or G01 Z-1 F20 for feed down. The simulation shows if you are following the path and if you look on the side of the simulation you will see the Z axis move into the material, if it does your program is correct. Can I suggest you post the program list for members to look at as it could be something very simple you are missing.
« Last Edit: January 08, 2017, 10:19:39 AM by jimthefish »

Offline Tweakie.CNC

*
  • *
  •  7,952 7,952
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Sorry to be a pain again but
« Reply #2 on: January 08, 2017, 10:48:29 AM »
As Jim has said, zip and post your Gcode file then it can be checked.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Sorry to be a pain again but
« Reply #3 on: January 08, 2017, 12:28:00 PM »
thanks for the speedy replies . I really haven't got much idea what I'm doing at the moment , but ive followed tutorials in artcam  to create the vectors and toolpaths and then mach 3  to create the logo
the z axis moves fine through the keyboard as do the others too so I'm confident its just getting familiar with the whole process . ive uploaded  a zip of the logo I want to design in g code . I'm just thinking now ,if I may have saved the file under the wrong type as theres a few mach 3 file types?
              really do appreciate your help and patience
                                   cheers jim
Re: Sorry to be a pain again but
« Reply #4 on: January 08, 2017, 12:42:06 PM »
Hi cant open that file, can you save it from the MACH editor as a text file then we can run it on our Mach system to look for errors.
Re: Sorry to be a pain again but
« Reply #5 on: January 08, 2017, 01:00:08 PM »
HI THERE . IVE SAVED IT AS A NOTEPAD FILE IS THAT OK ?
Re: Sorry to be a pain again but
« Reply #6 on: January 08, 2017, 02:15:47 PM »
I assume you have set the Z 0 (zero) as the top of the component. If so your program will run at the top of the component as you don't have a Z minus value in the program stack.
Insert a line immediately after the line that sends the tool to Z 0 with another line of programming telling it to cut into the material
for example
G01 (feed) Z- **(what depth you want) then a feed rate F** (the feed your using for cutting)

Be careful as CNC machines are very unforgiving if you put the wrong values in.
Re: Sorry to be a pain again but
« Reply #7 on: January 08, 2017, 03:02:54 PM »
thanks ill try this tomorrow . am I right in thinking this should be done in artcam ?or the settings in
mach 3 when I'm calibrating the motors ?
Re: Sorry to be a pain again but
« Reply #8 on: January 08, 2017, 03:14:31 PM »
Yes but remember CAD needs you to put in the values in a specific order, I don't use any CAD software I used to teach basic CNC in the 1990's so don't use or trust myself to use it as I'm a part time hobby machinist. You need to used CAD software everyday to become confident and not make errors. I forgot to say remember the tool will be in the material when its finished machining so make sure after the last cut there is a positive Z value. Something my students forgot to do, they would admire their work only to find a groove from the bottom of the component cut to the home position.
« Last Edit: January 08, 2017, 03:30:25 PM by jimthefish »
Re: Sorry to be a pain again but
« Reply #9 on: January 08, 2017, 03:41:04 PM »
Just had a second look and your program does have a z 0 retract value at the completion of the program. And yes it looks as if you have forgot to enter a cutting depth in your CAD values, so the cutter just touches the top of the component. Can I suggest you practice putting some simple geometric shape programs in by hand to grasp the basics of CNC before you trust CAD software. Errors on CNC programs can be very expensive mistakes.
Best of luck in your CNC machining its a great skill to learn and lots of fun