Hello Guest it is November 15, 2019, 07:24:52 AM

Author Topic: Homming probleme with Y axis  (Read 1075 times)

0 Members and 1 Guest are viewing this topic.

Homming probleme with Y axis
« on: January 02, 2017, 09:14:16 PM »
Hi everyone, does anyone already have this problem ?  I've two motor on y axis , A  motor slave to Y .  I've independent home switch for each motor . When engage homing, only A motor turn .. ( its like  if the 2 motor are not slave , but on jog , they works good ) .. need help  pleese !
Re: Homming probleme with Y axis
« Reply #1 on: August 11, 2017, 06:15:05 AM »
I'm having same problem, anyone have a solution?

Online Tweakie.CNC

*
  • *
  •  7,997 7,997
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Homming probleme with Y axis
« Reply #2 on: August 11, 2017, 07:20:59 AM »
Sounds like you need to edit the button script for Ref all Home.

DoButton(24) will home the Z axis.
DoButton(22) will home the X axis.
RefCombination(9) will home the Y and A axis together.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Homming probleme with Y axis
« Reply #3 on: August 11, 2017, 10:41:37 AM »
I'll try that when i get home. In my case i dont have independent homing switches for y and a. Will it still work? Or should i put in a switch ...which i dont want to do since then the gantry will wrack out of square is the switxhes aren't perfectly aligned.
Re: Homming probleme with Y axis
« Reply #4 on: August 30, 2017, 12:58:03 PM »
I use these proximity sensors on my Y and A axis. https://makerparts.ca/collections/power-control/products/6-36vdc-proximity-sensor?variant=13689184516

By turning the lock nuts you can micro adjust the projection of the sensor so that your gantry auto squares every time you home. CNCRouterParts has a good video showing this in action and the theory is covered in many threads here.