Author Topic: homing problems Hicon and Mach4  (Read 1949 times)

0 Members and 1 Guest are viewing this topic.

Offline a3dcreator

  • Active Member
  • Posts: 45
    • View Profile
homing problems Hicon and Mach4
« on: December 28, 2016, 12:15:50 PM »
Hello I am having some homing Problems with the Hicon Integra and Mach4.
It seems to trigger an Estop but never moves back like its supposed to to get out of the estop state and away from the sensor.
here are some images that show my settings in mach and hicon.

im just trying the Y axis for now.

any help would be greatly appreciated.


Offline a3dcreator

  • Active Member
  • Posts: 45
    • View Profile
Re: homing problems Hicon and Mach4
« Reply #1 on: December 28, 2016, 01:27:55 PM »
here are 2 more images.
debug log and machine diagnostics.
as you can see its triggering the sensor. but does not behave like a home. instead just triggring an ESTOP.

Offline festlv

  • Active Member
  • Posts: 3
    • View Profile
Re: homing problems Hicon and Mach4
« Reply #2 on: December 28, 2016, 04:55:29 PM »
VSI Device manager has an option to configure EStop pins directly in motion controller- have you checked there?

I am using similar setup and I don't have such issue.

Offline TOTALLYRC

  • Active Member
  • Posts: 834
    • View Profile
Re: homing problems Hicon and Mach4
« Reply #3 on: December 28, 2016, 07:32:40 PM »
You have your soft min and max set to zero. Try disable soft limits then test.

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.

Offline a3dcreator

  • Active Member
  • Posts: 45
    • View Profile
Re: homing problems Hicon and Mach4
« Reply #4 on: January 02, 2017, 12:58:13 AM »
thank you thats exactly what it was.
the estop pinn was configured to use pin 0.
i just used a different pin and now it works.

thanks for your help!