Hello Guest it is November 17, 2019, 07:29:06 AM

Author Topic: Strrange sound of stepper motor Mach3  (Read 2133 times)

0 Members and 1 Guest are viewing this topic.

Strrange sound of stepper motor Mach3
« on: December 22, 2016, 12:14:18 PM »
Hello while I have builded small CNC
could you someone know what could be the source of strange sound of my stepper motors? Its like thud, thud every about 1 second sometimes not even every second.. all three axis. Even if I unmonted the rails and test only motors its the same. I am running on Mach3.
Was thinking maybe too long cables or something in electronic?

Power source 24V 10A
Drivers DM420A
Steppers Nema17

Thank you
« Last Edit: December 22, 2016, 12:16:06 PM by zdenekrejci »
Re: Strrange sound of stepper motor Mach3
« Reply #1 on: December 22, 2016, 12:48:23 PM »
Hi
I had something like that a while back, the coupling from the motor  was slipping as it was not tight would make a thud sound
Bill
Re: Strrange sound of stepper motor Mach3
« Reply #2 on: December 22, 2016, 01:02:04 PM »
I have found now that when I increase microsteps its OK the higher the better but I need to run at lower speed and higher torque.
But still dont know whats causes this behavior.
Was thinking if its not something with Mach3.


More ideas?
Re: Strrange sound of stepper motor Mach3
« Reply #3 on: December 22, 2016, 02:43:14 PM »
The problem still remains even when disconected from rails

Offline RICH

*
  • *
  •  7,371 7,371
    • View Profile
Re: Strrange sound of stepper motor Mach3
« Reply #4 on: December 22, 2016, 04:15:45 PM »
Could be ringing on the pulse instead of a nice square wave signal.
Check with an o'scope.

Another Chinese Drive ( never heard of the one you listed)?

If bad pulse from computer solutions are limited.
But make sure everything is configured, wired , etc.  correctly for what you have.

RICH
« Last Edit: December 22, 2016, 04:20:18 PM by RICH »

Offline mc

*
  •  381 381
    • View Profile
Re: Strrange sound of stepper motor Mach3
« Reply #5 on: December 22, 2016, 06:29:22 PM »
Do all the axis do it at the same time?
If they are, it could be a power supply issue.
Re: Strrange sound of stepper motor Mach3
« Reply #6 on: December 23, 2016, 04:55:17 AM »
Ye it could be because the chinese stuff.
Power supply:
I thing its not the power supply if I connect only one axis its the same.

I am going to try today my old drivers I made a long time ago with the rest of the present system hopely will see where its the problem.

Offline RICH

*
  • *
  •  7,371 7,371
    • View Profile
Re: Strrange sound of stepper motor Mach3
« Reply #7 on: December 23, 2016, 06:48:50 AM »
- Post your xml file.
- Post info on a manual for your drive.
- What version of Mach are you using.
- What is the make of or what kind of computer are you using?

FWIW,

RICH





Re: Strrange sound of stepper motor Mach3
« Reply #8 on: December 23, 2016, 01:59:39 PM »
OK frends I have connected Mach3 with the main control unit "dont know how to call it in english its between PC and the drivers" so connected to my old drivers and its the same problem. So its the unit OR PC OR Mach3

On your question I am using version R3.042.020 and have no manual for my drivers I only found simmilar the rest just gessed but now I can see its not the drives.
My PC canot say what it is just found some old stuff and put it together will try my friends PC.

What you mean xm file? Mach3 settings? If so and its in the mach3 folder whats its name? Will send it.
Re: Strrange sound of stepper motor Mach3
« Reply #9 on: December 27, 2016, 01:30:45 PM »
Hi there can I have one more question?
I am running my CNC with Mach3 and there is a thing like slowing down. But when I mill PCB board its doing kind of rounded corners. Is there a way to fix this?

Thank you