Hello Guest it is February 27, 2021, 11:04:37 PM

Author Topic: Completely disable G43 tool length compensation / offset  (Read 2532 times)

0 Members and 1 Guest are viewing this topic.

Offline Zaae

*
  •  119 119
    • View Profile
Completely disable G43 tool length compensation / offset
« on: December 10, 2016, 08:15:09 PM »
Hi folks,

I've been using Mach 3 for many years, and from time to time I've run into this problem, but lately it's becoming more of an issue, since we're very busy.

I do not, and never have used tool length offsets. All of the entries in the tool table (should) be zero. I use a touch plate for zeroing my Z.

My Gcode processor puts out a G43 command for every tool change, in thousands of files, and normally everything works fine. Occasionally, a tool offset will appear in the table, that I did not put it there. It's seemingly random. Sometimes the offset is on one tool, sometimes on another, completely unrelated to the first. Sometimes the offset is 1 mm, sometimes 3mm, other times it's over 10mm! I just don't know where they come from!

I can run the same two files all day long, and suddenly, in the middle of a batch, this stupid tool offset appears in the tool table, changes my over all depth of cut, breaks a blade, ruins the part, or often causes a crash from cutting too deep.

It's our busy season, and short of doing a re-install of Mach 3, I'm at a loss what to do next. I'm aware of the offsets menu, and the Tool Offset LED is off. Normally, all the entries in that screen are zero. When I see this problem occur, I DO see the offset in the Z Offset box on the right side of that screen.

Is there some way to completely disable the tool length offset? Any other ideas?

Thanks!
Z

Offline Davek0974

*
  •  2,606 2,606
    • View Profile
    • DD Metal Products Ltd
Re: Completely disable G43 tool length compensation / offset
« Reply #1 on: December 11, 2016, 03:10:13 AM »
Have you got a G49 (cancel tool length offset)  at the end of the file?

Maybe easier to edit your post processor to remove the G43?
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives.
Plasma table, Mach3 V062, Step motors, C&CNC THC.
Re: Completely disable G43 tool length compensation / offset
« Reply #2 on: December 11, 2016, 07:20:05 AM »
+1 on the get rid of the G43. Since Mach3 is what it is and you get this problem from time to time, modify your post to not have a G43 or edit the Gcode to get rid of the G43.

Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.

Offline Zaae

*
  •  119 119
    • View Profile
Re: Completely disable G43 tool length compensation / offset
« Reply #3 on: December 11, 2016, 10:55:04 AM »
Thanks guys, I was hoping that wouldn't be the answer, since I have literally thousands of files. I will remove it from the post processor, and write some code to remove it from existing files, I don't think it will be too difficult.

There was no G49 at the end, instead it was near the beginning of each file. I had also checked the box in config to cancel tool offsets at the end of the file, or rewind.

Z

Offline Zaae

*
  •  119 119
    • View Profile
Re: Completely disable G43 tool length compensation / offset
« Reply #4 on: December 12, 2016, 02:28:55 PM »
Just as a follow up, I did remove the G43 commands from the post processor, so no new files will use it, and I wrote a program to scan, and remove (hopefully) all of the G43 commands from existing files. The testing I've done so far indicates success.

 If I ever figure out what was causing these erroneous entries in the tool table, I'll report back here.

Z