Hello Guest it is September 28, 2020, 05:14:59 AM

Author Topic: DRO Changes?  (Read 1704 times)

0 Members and 1 Guest are viewing this topic.

DRO Changes?
« on: November 29, 2016, 02:19:16 AM »
I can not figure this out for the life of me.  I have a simple part that I want to run on my plasma table.  It's just a square with 4 holes.  If I use the MDI screen to drive the torch around, everything works normally.  If I say G0 X1 Y1, the X and Y axes move one inch each.  I start with all my axes zeroed.  When I load the program, it automatically jumps the readout on the DRO to X100.*********  Y21.*********  Z200.*********.  Then, when you use MDI to move X and Y 1 inch each, the torch starts driving all the way across the table.  The only way to fix it is to close everything down and fire up Mach again.  Then everything is normal until I load the program again and everything goes squirrelly.  I have seen it do this with other programs as well. 

Any insight anyone can provide is greatly appreciated.

Here is the code as posted in Sheetcam:

N0010 (Filename: Caster Pads.tap)
N0020 (Post processor: Mach3 plasma.scpost)
N0030 (Date: 29/11/2016)
N0040 G20 (Units: Inches)
N0050 G53 G90 G91.1 G40
N0060 F1
N0070 S500
N0080 (Part: Caster Pads)
N0090 (Operation: Outside Offset, 0, T1: 060amp 1/4 steel)
N0100 M06 T1 F83.0  (060amp 1/4 steel)
N0110 G00 Z1.0000
N0120 X1.3155 Y1.3799
N0130 Z0.1181
N0140 M03
N0150 G04 P0.5
N0160 G01 Z0.0625 F4.0
N0170 G03 X1.3675 Y1.2545 I0.0887 J-0.0367 F83.0
N0180 G01 X1.4425
N0190 G03 X1.4425 Y1.5095 I0.0000 J0.1275
N0200 G01 X1.3675
N0210 G03 X1.3675 Y1.2545 I0.0000 J-0.1275
N0220 M05
N0230 G00 Z1.0000
N0240 X1.3155 Y3.1779
N0250 Z0.1181
N0260 M03
N0270 G04 P0.5
N0280 G01 Z0.0625 F4.0
N0290 G03 X1.3675 Y3.0525 I0.0887 J-0.0367 F83.0
N0300 G01 X1.4425
N0310 G03 X1.4425 Y3.3075 I0.0000 J0.1275
N0320 G01 X1.3675
N0330 G03 X1.3675 Y3.0525 I0.0000 J-0.1275
N0340 M05
N0350 G00 Z1.0000
N0360 X4.2555 Y3.1779
N0370 Z0.1181
N0380 M03
N0390 G04 P0.5
N0400 G01 Z0.0625 F4.0
N0410 G03 X4.3075 Y3.0525 I0.0887 J-0.0367 F83.0
N0420 G01 X4.3825
N0430 G03 X4.3825 Y3.3075 I0.0000 J0.1275
N0440 G01 X4.3075
N0450 G03 X4.3075 Y3.0525 I0.0000 J-0.1275
N0460 M05
N0470 G00 Z1.0000
N0480 X4.2555 Y1.3799
N0490 Z0.1181
N0500 M03
N0510 G04 P0.5
N0520 G01 Z0.0625 F4.0
N0530 G03 X4.3075 Y1.2545 I0.0887 J-0.0367 F83.0
N0540 G01 X4.3825
N0550 G03 X4.3825 Y1.5095 I0.0000 J0.1275
N0560 G01 X4.3075
N0570 G03 X4.3075 Y1.2545 I0.0000 J-0.1275
N0580 M05
N0590 G00 Z1.0000
N0600 X0.8640 Y3.0704
N0610 Z0.1181
N0620 M03
N0630 G04 P0.5
N0640 G01 Z0.0625 F4.0
N0650 G03 X0.9600 Y3.1664 I0.0000 J0.0960 F83.0
N0660 G01 Y3.3825
N0670 G02 X1.1800 Y3.6025 I0.2200 J0.0000
N0680 G01 X4.5700
N0690 G02 X4.7900 Y3.3825 I0.0000 J-0.2200
N0700 G01 Y1.1800
N0710 G02 X4.5700 Y0.9600 I-0.2200 J0.0000
N0720 G01 X1.1800
N0730 G02 X0.9600 Y1.1800 I0.0000 J0.2200
N0740 G01 Y3.1664
N0750 M05
N0760 G00 Z1.0000
N0770 X0.0000 Y0.0000
N0780 M05 M30

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: DRO Changes?
« Reply #1 on: November 29, 2016, 02:36:19 AM »
Remove this line from your code, restart Mach, zero and load the code and see if it behaves.
N0040 G20 (Units: Inches)

If it does then sounds like your machine may be set to metric for native units.

If that is not the problem then attach your xml and someone will take a look.

Hood
Re: DRO Changes?
« Reply #2 on: December 02, 2016, 01:02:16 AM »
Okay, taking that line out, allowed the program to work properly, but has left me more confused than ever.  I have Mach3 installed on 2 computers.  When I go to "Config", "Select Native Units", both installations are set to "MM".  One computer ran it just fine and gave me no problems.  That's the computer on my desk from which I simulate everything.  The one for my plasma table is the other and it is the one that screwed up the DRO readings immediately upon loading the program. 

If that was all it was, I could sleep tonight.  But I have run programs that I hand wrote in inches, (but without calling a G20) and they ran fine on the plasma table and the measurements were very close to correct.  How is this possible if I'm telling the torch to move, say, 6 inches and it thinks I'm saying 6mm?

I'm attaching my XML in case you still want to look at it.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: DRO Changes?
« Reply #3 on: December 02, 2016, 04:52:37 PM »
Ok so first question to ask is, when you first start Mach, home, move to a start point and zero then command via MDI G0X1, does the axis move 1mm or 1 inch?
Hood
Re: DRO Changes?
« Reply #4 on: December 02, 2016, 05:44:10 PM »
It'll move 1 inch.  I have cut a few test parts that came out correct.  But then again, I suppose that makes sense if we calibrated it while set in metric mode.  And by calibrate, I mean, we told it to move 50 inches and then adjusted the values  in the settings until the movement reflected the command.

Do I change it to inches via the "Config" - "Select Native Units" setting?  I recall there being a cautionary note that pops up though I can't remember what it said.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: DRO Changes?
« Reply #5 on: December 02, 2016, 06:38:41 PM »
Ok, so you have the native units as mm but you have configured it so that a 1 unit move makes the machine move 1 inch rather than 1mm.
So what you want to do is change the native units to Inch and restart and the machine should now be as intended and you should not have to change the steps per unit as they are already the equivalent value for inch movements. You can


Hood