Hello Guest it is November 15, 2019, 02:12:46 AM

Author Topic: Parallel port configuration  (Read 8842 times)

0 Members and 1 Guest are viewing this topic.

Parallel port configuration
« on: November 25, 2016, 09:00:23 PM »
Hello, I have been building my plasma table for awhile now and have been working on RF shielding issues. I had my machine operating on a Compaq PC with XP. It worked ok except for the HF issues. Computer quit and I got a Dell with XP but I cant get it to operate my machine. I have checked to pins on the parallel port and for some reason its not putting out the propper sygnals to the pins.

Pins,2,6,and 25 have 3.3 volts with program sitting idle.

Pins 10,11,12,13,and 24 have 4.3 volts all other pins have 0 volts. I have assigned pins in motor outputs and tested with meter and I get readings that do not correspond the the control inputs
 Help Please

Thanks

Online Tweakie.CNC

*
  • *
  •  7,993 7,993
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Parallel port configuration
« Reply #1 on: November 26, 2016, 02:05:03 AM »
Try measuring the voltages again using LPT pin 25 as the common (-ve terminal of voltmeter).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Parallel port configuration
« Reply #2 on: November 26, 2016, 01:34:08 PM »
Hello Tweakie, Thanks for the reply. I checked them again using pin 25 as common and the results were different.
Pin 2,4,7,8 had 3.2 volts. Pins 10,11,12,13, and 24 had 4.2 volts.
 Does this tell you anything?

 It seems to me to be a configuration froblem but I have not been able to figure it out.

Online Tweakie.CNC

*
  • *
  •  7,993 7,993
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Parallel port configuration
« Reply #3 on: November 27, 2016, 01:43:59 AM »
Voltages on the various pins can be anything when Windows starts but once Mach3 starts they will be under control (assuming you have the Mach3 parallel port driver installed, enabled and the correct Port address entered).

From your measurements my guess is that your onboard LPT port is bad.
Pins 18 to 25 should all be 0 volts in relation to each other (pin 24 to 25 should not measure 4.2 volts).

PCI parallel port cards are cheap and easy to obtain, I would be inclined to try one and see if that resolves the problem.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Parallel port configuration
« Reply #4 on: November 27, 2016, 11:48:04 AM »
Thanks for the help, I appreciate the help
 I will order one and see if it fixes the problem.

Any think in particular I should look for when I order one?
Re: Parallel port configuration
« Reply #5 on: November 27, 2016, 01:50:15 PM »
Rosewill Single Parallel (SPP/PS2/EPP/ECP) Universal Low-Profile PCI card Components Other RC-302

Will this one be a good choise.

Online Tweakie.CNC

*
  • *
  •  7,993 7,993
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Parallel port configuration
« Reply #6 on: November 28, 2016, 02:44:52 AM »
Unfortunately I can't say for certain that any particular card will or will not work.
If you have doubts or do not want to take the chance then it may be best to obtain one from a reputable supplier (such as CNC4PC for example) who can guarantee compatibility.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Parallel port configuration
« Reply #7 on: November 28, 2016, 03:40:36 AM »
The Lava cards work well and give 2 port from one card.
I don't have the number in my head but if you can't find it here on the Machsupport forum by searching I can find it later today.
 I found mine on ebay.
Like this one; http://www.ebay.com/itm/Lava-MOKO-L76-0-PCI-Parallel-Interface-Card-1-External-Port-1-Internal-Port-/231738667008?hash=item35f4b37000:g:26gAAOSwmmxW2kJX

The key is to make sure that it is not a USB implementation of a pport but a true pport.


Mike
We never have the time or money to do it right the first time, but we somehow manage to do it twice and then spend the money to get it right.