Hello Guest it is December 15, 2019, 09:00:14 AM

Author Topic: Win7, MACH3, UC100 Micro stepping problem  (Read 2381 times)

0 Members and 1 Guest are viewing this topic.

Win7, MACH3, UC100 Micro stepping problem
« on: October 28, 2016, 11:20:13 PM »
Hi all,
Switched Mach3 to an older Dell latitude laptop with Win7 pro service pack 1, 32-bit, 1.60ghz,1 gig ram, after my last xp machine died.  Purchased a UC100 to use between the laptop and a g540.  Per a recommendation, running Mach3 version R3.043.062.  No external mice used, touch pad only.

I get random freezes while trying to micro step using the Ctrl and any direction key.  No programs loaded, just the random stops while micro stepping.  If i reset, then try a micro step, it stops all movement.  In order to micro step, i have to move the motors under normal direction changes a few times to get it to micro step.  Sometimes it works, sometimes it wont.  Every time it looses motion control, i have to hit the reset button in Mach in order to move the motors.  No mouse freeze or any Mach buttons stop working. 

I just turned off the usb suspend feature without testing the results tonight.  Is there anything else I'm missing or could try?

I have also disabled all power saver settings.
Re: Win7, MACH3, UC100 Micro stepping problem
« Reply #1 on: October 29, 2016, 12:24:01 AM »
Well, running it, disconnected from the g540, was still able to get it to stop all keyboard motion inputs while micro stepping.  Still seems like random halts...sigh.
Re: Win7, MACH3, UC100 Micro stepping problem
« Reply #2 on: October 29, 2016, 10:40:20 PM »
Went through msconfig and turned off the printer spooler and a few network drivers.  So far, no random freezes.  Wondering if I was somehow hitting  the print screen button as the laptop keys are close together.