Hello Guest it is May 14, 2021, 07:28:42 AM

Author Topic: Steps aren't consistent positive to negative  (Read 1493 times)

0 Members and 1 Guest are viewing this topic.

Steps aren't consistent positive to negative
« on: October 28, 2016, 08:03:50 PM »
Hey guys!  Having an issue I can't figure out myself, so I'm finally giving in & joining to post about it rather than continue searching.

I'll give as much info as I think you will need, but if I miss anything, just let me know what you need from my end so we can carry on. 

I have a 10x50 knee mill retro'd to CNC using a microkinetics kit.  I didn't like their software, and am already semi-familiar w/ mach3 from a plasma cutter. 

I have a dell computer which was "rebuilt" (caps replaced inspected etc), and am running XP.  Steppers are 1.8* rev/step, and I have halfstep set on the drivers, so
I have 400steps/rev.  Add in the 2:1 reduction, and 5TPI ball screw, and I'm at 4000 steps/inch.  Not the best of resolution, but it works for now.  Accel is set to 3, &
velocity is 90.  step & dir pulse widths are 5us, but not worthy is I'm getting the same error even up at 15us.  25K (lowest) kernel speed.

Here's what's going on.  With backlash comp turned off, my X axis wanders off in the negative direction.  I get a full calibrated .001" step per the dial indicator & mach DRO,
in the positive direction, but the first step in the negative, and I only move some percent of that, maybe 50%.  It isn't a full .001" step, though.  Each step in the negative there
after, is a full step.  It only happens at the change from positive direction, to negative direction.  Once again, backlash comp is turned off. 

So I assumed there was binding going on somewhere in my mechanical system, maybe the gib's binding on that initial direction shift etc.  To rule it out I disconnected the stepper
entirely from the lead screw, and decided to free spin the stepper & pulse it back & fourth.  I used a pointer & a mark on the pulley, and sure enough, you can watch the mark
wander away from the pointer, as you toggle the jog from =.001" to -.001" over & over & over.  (I'm hitting left arrow, right arrow, left arrow, right arrow, etc repeating.)

I thought'd I'd solved it this AM when I saw my pulsewidths for X were 0us, and I upped them both to 5us.  All was good until it sat idle for a while, and the problem had returned
when I came back to use it. 

I'm lost haha.  I'm hoping this is on the software side of things but we'll see once I get some more educated assitance.

Thanks, look forward to getting this going!
Re: Steps aren't consistent positive to negative
« Reply #1 on: November 11, 2016, 03:06:43 PM »
not sure what's going on but there is probably some things you can do to narrow the problem down.

I notice that you say the problem occurs on the X axis only. Is that correct?

If so try disconnecting the Y axis stepper and drive it with the X axis driver. If the 'creep' problem
now happens on the Y axis then the fault is the X axis driver or its pulse inputs.

You could also try driving the X axis stepper with the Y axis driver to confirm the X axis stepper is OK.
Stepper motors are pretty simple and unlikely to fault in the way you describe but its an easy
test. Be a shame to spend time/money/frustration only to find that it was something this simple!

Another thing that might be worth investigating is to go 'full step' Switch the microstepping off and
try the same test. I can't help but wonder if the driver is not microstepping indentically and symmetrically
in both directions.

Another simple test would be to feed the X axis stepper with the Y axis pulse/direction inputs. Would
prove whether the driver or its pulse inputs are faulty.

Let us know how you get on.

My wife left with my best friend...
     and I miss him!

Offline mc

  •  380 380
    • View Profile
Re: Steps aren't consistent positive to negative
« Reply #2 on: November 11, 2016, 06:50:19 PM »
Could be a direction setup time issue.

Depending on the drives, after the direction has been changed, they may need a certain amount of delay before the next step pulse. If this was the problem, then the drive can move one step in the wrong direction before then moving in the correct direction, so it ends up two steps of the desired position, and it is possible for it to only affect the direction change in one direction.

You could try flipping the Step Active High/Low option, or increasing the Dir Pulse setting on the motor tuning page.