Hello Guest it is October 17, 2019, 06:59:20 AM

Author Topic: Mach3 Turn X Axis issue  (Read 4013 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Turn X Axis issue
« on: October 19, 2016, 01:30:38 PM »
Hi all,

I'm relatively new on here and am after a little help.

I run a small machining business from home and have just purchased a Denford Orac CNC Lathe running on Mach3.

Z Axis runs perfectly and is bang on size wise, but the X Axis is way out and doesn't seem to repeat at all.

It was converted over last winter by the chap I bought it from and it has never really been used by him.

Any ideas on how to sort the problem, the solutions probably staring me in the face but I just can't see it!

Any help appreciated.

Thanks

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: Mach3 Turn X Axis issue
« Reply #1 on: October 19, 2016, 07:09:05 PM »
Steppers or servos?

You probably need to adjust the motor tuning for the x axis in configuration for that axis.

RICH
Re: Mach3 Turn X Axis issue
« Reply #2 on: October 20, 2016, 08:14:45 AM »
Thanks Rich,

The machine uses stepped motors.

The motor tuning appears to be correct, but the movement shown on the DRO doesn't translate to the movement on the machine?

I'm a bit baffled to be honest!

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: Mach3 Turn X Axis issue
« Reply #3 on: October 20, 2016, 10:33:49 AM »
motor tuning appears to be correct

It is either correct or not correct.
Calculate the steps per unit or Alt (6) menu selection and you will see in the lower left corner an Axis Calibration which can be used to set the
steps per unit.

Attached the xml file your are using.

RICH