Hello Guest it is October 20, 2019, 08:48:35 PM

Author Topic: in need of help!!  (Read 1694 times)

0 Members and 1 Guest are viewing this topic.

in need of help!!
« on: October 12, 2016, 02:31:43 PM »
Hello all,

I have a small cnc mill and am having quite a strange problem that I really need help with....

I have been using the machine for a couple of years now with no problem, but recently decided to change my CAM software to fusion 360. I like Fusion 360 better as it is a all in one package. I used to use CamBam to create my gcode and all was fine.

Recently I have designed a part in Fusion 360, a new hoover fiting for the mill. Through the CAM tab in fusion made the required toolpaths and outputed the gcode using the "mach3mill.cps" postprocessor. I ran some simulations before and it all seemed fine.

 
Now comes the problem....

The Cam tab in fusion360 has 4 process's, 3 cut fine but on the 4th it starts to drift on the y axis.

1. A slot around the outer edge.(2mm endmill)

2. 4 Holes for magnets.(6mm endmill)

3. 2 large holes. (6mm endmill)

4. The outer shape. (6mm endmill and Here's the problem)

It appears to drift upwards on the y axis by about 1mm on each pass around the outer edge. I have ruled out backlash and am 99% sure that its not missing steps. (If it is missing steps its doing it in exactly the same places, Everytime I run the code and only on the last toolpath.... VERY unlikey) It is as if it happens gradually over the course of one time around, There is at no point a recognizable "step". What I dont understand is why it can cut everything else fine but not the outside cut, In my opinion it has to be a software/ gcode problem.

I have also let the gcode file run until the end (cutting in the air) and once it was done told it to return to zero, Once it returned the y axis was off by about 10.5mm.

This is really strange to me for a few reasons:

1. The machine has worked fine for along time using code from cambam.

2. The machine apears to be missing steps, However Every time I run the code the result is the same. The first three processes cut fine then on the fourth it slowly drifts with no noticable missing of steps.

3.The machine very rarely misses steps.

I could really use some pointers as I am at a loss currently and dont know where to look next. ???

I have also posted the problem on the fusion360 forum, thinking it was a cam problem. But the code appears to be fine. here is the link to that post where there and files and photos: http://forums.autodesk.com/t5/computer-aided-machining-cam/possible-bug-with-cam-gcode-output/m-p/6615681/highlight/false

Thanks
Luke

Offline Davek0974

*
  •  2,580 2,580
    • View Profile
    • DD Metal Products Ltd
Re: in need of help!!
« Reply #1 on: October 12, 2016, 02:42:15 PM »
Is there anything different on the last process - heavier cut, faster speed, deeper cut??

Sounds very odd that its only doing it on the last process.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: in need of help!!
« Reply #2 on: October 12, 2016, 02:46:23 PM »
no the cut is done the same as all the other processes.

Offline Davek0974

*
  •  2,580 2,580
    • View Profile
    • DD Metal Products Ltd
Re: in need of help!!
« Reply #3 on: October 12, 2016, 02:53:39 PM »
And its missing steps when cutting in air?

Is there a motor coupling, belt pulley etc come loose somewhere?

Sounds like time to dig deeply into the mechanics I think, as its only one axis you have a good idea where to start ;)
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: in need of help!!
« Reply #4 on: October 12, 2016, 02:59:03 PM »
yes it is also drifting/missing steps in the air.

To be honest im not sure that it missing steps, Because it cuts the first processes fine and it has been working fine for a long time now. Also missing steps would be more noticable, It is as if it happens gradually.

The machine uses ball screws and the machanics looks and feels fine.
Re: in need of help!!
« Reply #5 on: April 01, 2018, 11:40:05 AM »
Hi Luke,
I also have a similar problem to the one you described, where the last simple step drifts off it's tool path, it's normally on a circle/oval and tends to occur in the same position each time I re-run the tool path.
Did you ever get a response on a possible solution, as i'm racking my brains.

Offline RICH

*
  • *
  •  7,367 7,367
    • View Profile
Re: in need of help!!
« Reply #6 on: April 02, 2018, 07:33:37 AM »
cooke86,
You can tell when your missing steps since many times you will hear it or the machine just goes off on in an uncontrollable way.
BUT
You can be missing steps and the above is not true. I can happen gradually, be repeatable, or random.

 I am thinking that for the first set of machining steps  your axis settings are fine BUT they are not appropriate for last machining step.
This can come about from the combination of having too an high acceleration and small moves. You won't hear the missed steps and difficult to even
monitor it.

Others reviewed and backplotted your code and said the code was good. Here is what I would suggest.
Just run the code for the last machining step and confirm that the problem is repeatable.
- If you have an external DRO display you add a  dwell in the code at strategic line locations in the gcode program and compare Mach's DRO verses
   the external DRO's. Another way is to code in a move to a known physical location and compare to Mach's DRO.
- Change the acceleration and velocity values for the axis. Cut them in half and see affect.

- Another way, in your case, is to change the small Y height moves, and test to see if the problem goes away.

Just do the above in a disciplined / logical way, not quick and dirty, since you want to know the result of each change what the problem really was.

For 3d work high acceleration is desirable for reducing machining time. Simply said, your stepper may not be have the acceleration capability required for the small moves that the controller is instructing. Know your machine and be carefull when using CAM, bad feedrates and impractical machine
tuning cause problems, the gcode generated from CAM and the controller instructions are good, just bad operator CAM input to the program.

Have Fun,

RICH
« Last Edit: April 02, 2018, 07:38:48 AM by RICH »
Re: in need of help!!
« Reply #7 on: April 03, 2018, 07:20:05 AM »
Hi Rich,
I have read your response and will look to implement those tests, however 1 thing I read up on yesterday pointed me to the fact that Mach3 doesn't run on 64 Bit operating systems. I have been running my CNC on 64 Bit Laptops since I had it, and I eliminated the Laptop as the issue as I recently bought a new one and was getting the same drifting issue. Both my new and previous Laptops were on 64 Bit OS.

Yesterday I have found an old 32 Bit OS desktop PC which I initially installed the Mach3 Demo software on, I have connected and reconfigured it and run the code that was causing my original drifting issue, the result was that it ran without issue. I am going to carry on testing various jobs that I had issues with.

I've now noticed that the CNC runs and sounds different, much smoother with less jerky movements, so a combination of 32 vs 64 Bit OS and motor tuning (Acceleration/Velocity) may have been the culprit. I will look to check the motor tuning settings again.

I have found this useful, with lots of pointers. I will post my results of my testing in the next couple of weeks when I can confirm if the issue has gone.
Cheers
Re: in need of help!!
« Reply #8 on: April 03, 2018, 09:06:15 AM »
Hi,

Quote
1 thing I read up on yesterday pointed me to the fact that Mach3 doesn't run on 64 Bit operating systems
This is incorrect. Mach3 runs perfectly well in either 32 or 64 bit OS's. What does not run in 64 bit OS's is Machs Parallel Port.

Mach should really be considered two  separate bits, one is the Windows application with its familiar GUI, and it will run on 32 or 64 bit no probs. The second bit is the parallel port (bit two),
really its a piece of driver code that runs at kernel level within Windows and takes numeric data from the trajectory planner/Gcode interpreter (bit one) to produce the required pulse streams
for the motor drivers. This chunk of code will only run on 32 OS's and commonly only very well on desktop machines as laptops power saving features often disrupt smooth operation
of the parallel port.

If you wish to run Mach on a 64 bit OS then you will need an external motion controller like a UC100 or ESS because you cant use Machs Parallel Port. Provided you have such a device then
Mach runs perfectly well with either 32 or 64 bit OS's. My normal machine platform is 32 bit Windows7 but have run my machine on occasion with my Windows8 laptop via an ESS and you
cant tell the difference.

Craig
My wife left with my best friend...
     and I miss him!
Re: in need of help!!
« Reply #9 on: April 03, 2018, 11:41:19 AM »
Thanks for the clarification Craig.
I'm running with the UC100 external motion controller, but I have noticed a difference in the way the CNC runs since I swapped over from my 64 Bit new Laptop to my old 32 Bit Desktop. I don't know why but it feels and sounds different when the CNC is now running.

I will carry out some adjustments on the motor tuning as RICH suggested in case these are set too high

Cheers, Kevin