Hello Guest it is December 08, 2019, 07:24:02 PM

Author Topic: Featurecam 2012 post for mach3 turn needed  (Read 14441 times)

0 Members and 1 Guest are viewing this topic.

Offline JDG3

*
  •  19 19
    • View Profile
Featurecam 2012 post for mach3 turn needed
« on: September 10, 2016, 05:02:14 PM »
Hi. I'm getting a shopmaster next week that comes with Mach3 installed/configured.
I'm learning Mach3 before it gets here,  and i have access to featurecam 2012 without support, tho.
I've tried all the posts here, but none are working, can anyone share with me if they have them?
I like featurecam better than other turning cam I've tried.
Thanks for the help.
Re: Featurecam 2012 post for mach3 turn needed
« Reply #1 on: November 09, 2016, 01:14:19 PM »
Hi there, just wondering if you had any luck finding a post processor from feature Cam 2012
to Mach3. In the Artsoft section download post, it mention that any fanuc should work. ???
I can not get it to work with any of fanuc post.
(DIY CNC with stepper motor step/Dir micro-stepping driver)
Any help would be greatly appreciated.
Thanks

Offline JDG3

*
  •  19 19
    • View Profile
Re: Featurecam 2012 post for mach3 turn needed
« Reply #2 on: November 09, 2016, 05:03:22 PM »
Are you using a lathe or mill?
I never got it to work to good. I think I used the  E Z path code, but it kept putting big arcs in the code.
All I had to do was delete the lines containing the arcs, the G2 codes.
When I bought the license for Mach, the NFS turn wizard worked for what I was doing, and I learned a lot more about g code by using it too.
The NFS turn wizard is a lot better than the free ones.
The Mach 3 post listed for featurecam had a redirect virus in it, that I found with malware bytes. It was driving me crazy.
Re: Featurecam 2012 post for mach3 turn needed
« Reply #3 on: November 10, 2016, 04:58:53 AM »
Hi, thanks for reply! I am using a 3 axis milling machine that I have assembled myself for hobby usage.
I used meshcam in the past and never had any issue. I am now using featurecam 2012
and I am having lots of issue depending on post processor used. Mach3 would not compile
the NC code depending on the post processor I use.
''Cannot use two g codes that both use axis values , Block = N4715 G0 G91 G28 Z0 M09
Line 941 "
or post processor e.g emco, ---Unknown word starting with r , Block = Program #Myfirst part
Line 0 -- When I delete all syntax problem, the result is completely wrong.


 

Offline JDG3

*
  •  19 19
    • View Profile
Re: Featurecam 2012 post for mach3 turn needed
« Reply #4 on: November 10, 2016, 08:21:19 AM »
The pics I promised, all done with artcam.
A lead knuckle mold, a .45 cal. ball mold, a coin and some photos.
« Last Edit: November 10, 2016, 08:24:17 AM by JDG3 »

Offline JDG3

*
  •  19 19
    • View Profile
Re: Featurecam 2012 post for mach3 turn needed
« Reply #5 on: November 10, 2016, 08:31:18 AM »
The mill that done them.

Offline JDG3

*
  •  19 19
    • View Profile
Re: Featurecam 2012 post for mach3 turn needed
« Reply #6 on: January 25, 2017, 09:57:47 AM »
I got my posts to work by adding G90.1 (arc center absolute), and checking reversed arcs in front tool post under Turn configurations in Mach3.
I was getting Crop circles:)

Offline JDG3

*
  •  19 19
    • View Profile
Re: Featurecam 2012 post for mach3 turn needed
« Reply #7 on: October 25, 2019, 06:38:10 AM »
New Featurecam post for Mach3 turn.

Offline JDG3

*
  •  19 19
    • View Profile
Re: Featurecam 2012 post for mach3 turn needed
« Reply #8 on: October 25, 2019, 08:01:45 AM »
Re edited the post. It wasnt inserting G95 for feed per rev