Hello Guest it is June 25, 2019, 08:55:41 PM

Author Topic: Mach 3 Display not showing G Code anymore  (Read 2286 times)

0 Members and 1 Guest are viewing this topic.

Offline GENX

*
  •  16 16
    • View Profile
Mach 3 Display not showing G Code anymore
« on: August 19, 2016, 08:39:22 AM »
Did some testing. I have the Demo mode.

I loaded the road runner from the stock templates. I noticed that the scale of the road runner was larger than my table. I have a Little Machine shop 3990 (Sieg X2).
So no problem I reduced the scale to .5 next to the DRO read out. All seemed to be working fine. I executed some test runs with a marker and it drew the road runner for me exactly to the scale it presented in relation to my table. My table is accurate in that the cross hairs accurately represent the homing limits I have set up.

Then I imported some gcode I had created for a new cut by fusion360.

I tried some real live cuts with this new G Code. It worked fine on the piece. I did have some user error and now I am attempting to recut the piece, But somehow now the g code loaded and tollbooth regenerated the display tool window does not show my Gcode as very big for the custom piece. Matter of fact I can not see it hardly at all If I go back and load the roadrunner it is now VERY SMALL in relation to my table display!

I can only see the stock road runner. If I Regen the toolpath it does not make my custom piece bigger either.
I have to change the scale to 20x to generate an image that is as big as it was when I initially set it up to be.
Before I could see a toolpath of the G code on my custom piece. Now I cannot see anything. I even executed the code and it Cut it right. I go back to the same G code and load it and I get nothing.

Any thoughts?

Offline GENX

*
  •  16 16
    • View Profile
Re: Mach 3 Display not showing G Code anymore
« Reply #1 on: August 19, 2016, 08:47:06 AM »
I might say the status: shows
Current point same as end point of arc, Block G2x19.763

 Maybe Mach3 doesn't like the G code? But why is the road runner now so small now compared to my table when before it was too big to fit?

Offline Tweakie.CNC

*
  • *
  •  7,817 7,817
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 Display not showing G Code anymore
« Reply #2 on: August 19, 2016, 09:22:54 AM »
The Roadrunner Gcode file was created in Imperial (Inch) units and your machine is set-up in metric units so 1 inch of file shows as 1 mm on your display.
The Roadrunner file should have had G20 near the beginning to tell Mach3 that it was in Inch units but this was omitted (either by error or deliberately to teach us all more about Gcode  ;)) thus the problem.

If you add G20 to the beginning of your Roadrunner Gcode file then it should all work and display correctly.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline GENX

*
  •  16 16
    • View Profile
Re: Mach 3 Display not showing G Code anymore
« Reply #3 on: August 19, 2016, 09:33:09 AM »
I need to learn more about G Code for sure.

I had set the machine up in imperial, but drew the G code of my custom piece in Metric.

Mr Tweakie,
Any resources(books, links) you may provide for a novice on G code will be happily devoured.....

I added G20 to the top of Code at the very first line and road runner disappeared. 

Offline Tweakie.CNC

*
  • *
  •  7,817 7,817
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 Display not showing G Code anymore
« Reply #4 on: August 19, 2016, 10:00:01 AM »
Quote
Any resources(books, links) you may provide for a novice on G code will be happily devoured.....

I have never read it but I understand that to learn Gcode this is the book to have “CNC Programming Handbook 3rd Edition” by Peter Smid.

Quote
I added G20 to the top of Code at the very first line and road runner disappeared.

The extents of the Roadrunner Gcode model are probably greater than your soft limits table size settings. Turn off soft limits and see if the display re-appears.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline GENX

*
  •  16 16
    • View Profile
Re: Mach 3 Display not showing G Code anymore
« Reply #5 on: August 19, 2016, 10:26:09 AM »
Roadrunner still disappeared.

I read something about the IJ Mode being absolute or Inc. and to change the status. I don't know what those mean or do. But I know there is a Gcode 90.1 in my custom piece....

Offline Tweakie.CNC

*
  • *
  •  7,817 7,817
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach 3 Display not showing G Code anymore
« Reply #6 on: August 19, 2016, 10:43:21 AM »
I know nothing of your Custom Piece but G90.1 will place Mach3 into Absolute mode when it comes to reproducing arcs.

Different CAD/CAM software may use one of two different methods for defining and producing the Gcode for arcs - some prefer Incremental whilst others prefer Absolute. If arcs are used within a Gcode file the appropriate G91.1 / G90.1 should always be specified but unfortunately, some post-processors do not do this and confusion is created within Mach3 (the common cause of the crop circles).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.