Hello Guest it is December 15, 2019, 07:45:18 PM

Author Topic: Motor 0 Pulse Count Error caught on buffer verify ### ###  (Read 7212 times)

0 Members and 1 Guest are viewing this topic.

Motor 0 Pulse Count Error caught on buffer verify ### ###
« on: August 12, 2016, 10:17:26 AM »
Mach 4.2.0.2914. We've recently been experiencing an issue where we receive the following error message, "Motor 0 Pulse Count Error caught on buffer verify -18513.000000 -0.000000", with varying numbers. This disables Mach4 and stops our GCode from proceeding. We aren't even using Motor 0 and it's unchecked in Configure -> Mach -> Motors. This only seems to happen if we haven't been running anything for a couple of hours (i.e. the start of the day) and then it seems to go away. Any advice?

(This was reposted from under Mach4 general advice. I was recommended to post here instead)
« Last Edit: November 01, 2016, 12:48:00 PM by Vital System Support »
Re: Motor 0 Pulse Count Error caught on buffer verify ### ###
« Reply #1 on: August 12, 2016, 12:17:22 PM »
Hello,

Have you updated to the latest Mach4 build, HiCON plugin, and firmware?

You can verify this by checking the HiCON status window. The plugin and firmware versions are listed on the upper left of the screen.

If motor 0 is disabled, is it also unmapped in the Axis Config?


-Marc
Vital System Inc
Re: Motor 0 Pulse Count Error caught on buffer verify ### ###
« Reply #2 on: August 15, 2016, 10:18:25 AM »
I've just updated the plugin version and integra firmware to the most recent. The axis is also unmapped. I'll pay attention to the bug over the course of the week to see if it's been fixed.