Hello Guest it is May 20, 2019, 07:07:12 PM

Author Topic: Another Newbie that cant get the motors to turn....  (Read 1499 times)

0 Members and 1 Guest are viewing this topic.

Another Newbie that cant get the motors to turn....
« on: August 08, 2016, 04:41:39 PM »
Hello everyone, I would like to start by thanking all the knowledgeable contributors that have helped me get as far as I have on my G0704 CNC conversion over the last few years.  I have searched high and low and read countless forums to no avail so here I am.  I got everything communicating correctly and green lights on my ESS and my motors lock.  When I jog in Mach the DRO values change but motors do not turn.  I believe that everything is wired correctly as I have double checked it a hundred times and compared multiple diagrams, etc. I have reinstalled Mach several times.  I believe my ports and pins are set correctly.  I have tried switching active lows.  I have changed motor tuning and tried different pulse widths.  I have changed micro steps.  I have adjusted the dip switches on my drivers to multiple settings.  I am running out of ideas.  I will post my XML when I get home from work.

Here is my current setup:
Windows 7 pro 64 bit.
Mach 3 Demo mode
Ethernet Smooth Stepper with C25 BOB
(3) KL-8070D Motor Drivers
Keling Kl-600-48  Power Supply powering drivers
Keling KL-10-5  Powering ESS
(2) KL23H2100-50-4B  Stepper motors on the X&Y
KL34H295-43-8A  Stepper Motor for Z wired bipolar series

Ports and Pins (off the top of my head)
x Axis   Enabled   2,3    Step Port 1, Dir Port 1
y Axis   Enabled   4,5    Step Port 1, Dir Port 1
z Axis   Enabled   6,7    Step Port 1, Dir Port 1

Thanks in Advance for any ideas.

-Tyson
Re: Another Newbie that cant get the motors to turn....
« Reply #1 on: August 08, 2016, 05:16:43 PM »
Can you post some pictures of the wiring between the BOB and the stepper drivers?  My guess is the trouble lies somewhere between those two components, especially since you said the motors do lock when the system is fired up.

Stephen "Highspeed' Kruse
Re: Another Newbie that cant get the motors to turn....
« Reply #2 on: August 08, 2016, 06:51:23 PM »
Here is a link to some photos.  Let me know if you see anything out of place.  Thanks again.

https://www.dropbox.com/sh/bmempfj64h8tjde/AAB_371hSQFH_OwcKj0duFqwa?dl=0

-Tyson

Re: Another Newbie that cant get the motors to turn....
« Reply #3 on: August 08, 2016, 09:50:09 PM »
I think I see the problem.  Thanks for the pics.

It appears you have everything wired correctly on the stepper driver end.  You even correctly have the PUL+ and DIR+ tied together.  However....  in that configuration, the common lead should be tied to +5V, not GND.  This is assuming you have a common anode configuration on your BOB which seems to be the more common configuration.  If you have a common cathode setup on your BOB then the two pins that are tied together on the driver need to be put on the PUL- and DIR- and the other two leads would move to the PUL+ and DIR+ pins.

The easiest way to test this is to move the GND connection on the BOB for one axis to the 5V pin.  If that axis then moves, you'll know you've got it right.  Just do the same for the other axes and you're good to go.  If not, put it back where it was and reverse the connections as described in the first paragraph.

Hope that helps,

Stephen "Highspeed" Kruse
Re: Another Newbie that cant get the motors to turn....
« Reply #4 on: August 08, 2016, 11:08:29 PM »
Stephen
Thanks for the suggestion.  I had actually tried this about 5 minutes before reading your post. I swapped the wires at the driver like you described and still no luck.  I believe it is a common cathode, as I get continuity between ground and common.

I also uninstalled Mach3 and installed Mach4 just to eliminate the software and I get the same result.  Green lights on the board that indicate Mach is communicating and in control.  Throw some G code in the MDI and the DRO responds as expected but motor does nothing, no noise, no movement, just locked.

FYI. I know very little about electronics(just enough to be dangerous)  I checked for output with a multi meter at the BOB between common/ground and the pul- and I could see a little voltage when the program was running then back to zero when program was complete.  This leads me to believe the issue is between the BOB/Driver/Motor.  I think I will call Keling in the am to see if they can advise.

Goodnight
-Tyson
Re: Another Newbie that cant get the motors to turn....
« Reply #5 on: August 08, 2016, 11:40:39 PM »
Continuity between ground and common would be a common anode connection.  Try moving that connection on the BOB that has one red wire on the GND connection over to the 5V connection.  That will get one of your drivers moving a motor I'm sure.  If it does, then you need to move the other (2 red wires) connection from the other GND connection to a 5V pin as well.

The little bit of voltage you see on the pul- pin is the averaging of the voltage a multimeter will show when pulses are present so Mach3 and the BOB are working.  But bear in mind, those are positive pulses.  Positive pulses going into the negative input will give no response if the other end is connected to ground as the input diode on the opto-coupler will be reversed biased.  Putting the 5V on the positive input will forward bias the input stage whenever the pulse on the negative pin goes LOW so you need to make sure to set Active Low for both signals on all three axis outputs.  This will ensure smoothest operation of the motors.

I have the exact same stepper drivers and that's how I have mine working.  (5V on the + pins and the inputs on the - pins with active low signals.)

Stephen "Highspeed" Kruse
Re: Another Newbie that cant get the motors to turn....
« Reply #6 on: August 09, 2016, 12:00:26 AM »
Victory!!!

Well you were right.  I got lucky and figured it out before I read your last post, lol.  I was reading about my smooth stepper and apparently there are jumpers underneath my BOB that need jumped in order to provide power.  After that I tried it wired as is and got nothing, then I tried swapping the wires on the drivers again, like you suggested and BAM!! motor movement.  Played with motor tuning a bit and threw some basic code at it and it was a beautiful sight. 

I have been working on this project off and on for 2 years and invested over $5,000 rebuilding my little G0704, adding double ballscrews, building motor mounts, one shot lube, treadmill motor conversion with belt drive. This is a pretty amazing feeling to finally get the darn motors moving.  I feel like its all down hill from here.

Stephen, Thanks again for stepping up to the plate and pointing me in the right direction.  Maybe someday I will have an opportunity to pay it forward.

-Tyson
Re: Another Newbie that cant get the motors to turn....
« Reply #7 on: August 09, 2016, 12:57:47 AM »
Awesome!  I knew we'd get you going.  Good find on the jumpers.  I'll make a note of that one for future reference.  I know the feeling of that first triumphant movement on the motors.  Great job getting your CNC conversion on that G0704.

Definitely glad to help and hope, too, that you will someday be able to pay it forward.  Have a great time "making chips" my friend.  Good luck, Tyson.

Stephen "Highspeed" Kruse