Author Topic: Session ID mismatch  (Read 2308 times)

0 Members and 1 Guest are viewing this topic.

Offline Amtrim

  • Active Member
  • Posts: 7
    • View Profile
Session ID mismatch
« on: August 08, 2016, 09:21:01 AM »
I am getting a session ID mismatch. I replaced my HiCon Integra controller and installed the newest Mach3 firmware on it. I also reloaded Mach3 to make sure there wasn't any issues there, but I am still getting a session id mismatch.
« Last Edit: August 08, 2016, 02:50:07 PM by Vital System Support »

Offline Vital System Support

  • Active Member
  • Posts: 329
    • View Profile
Re: Session ID mismatch
« Reply #1 on: August 08, 2016, 12:13:03 PM »
Hello,

Did you upgrade the firmware using the files present from this download link?
http://www.vitalsystem.com/portal/motion/hicon/hicon_integra/Integra_Files.zip

We usually ship out the Integras using the latest Mach4 firmware and sometimes, people also download the Mach4 firmware instead of the Mach3 compatible firmware.

Also, it could be that your Mach3 plugin isn't updated? When a HiCON is detected by Mach3, it will print the plugin and firmware versions on the history log. Try and take a look there to see if the versions are all good.

-Marc
Vital System Inc.




Offline Amtrim

  • Active Member
  • Posts: 7
    • View Profile
Re: Session ID mismatch
« Reply #2 on: August 08, 2016, 01:09:31 PM »
Yes that link is the same firmware I downloaded to the controller.

Where is the history log located?

Offline Vital System Support

  • Active Member
  • Posts: 329
    • View Profile
Re: Session ID mismatch
« Reply #3 on: August 08, 2016, 01:33:17 PM »
Hello,

If you're using one of the default screens for Mach3 (like the 1024.set), then you should see a button labelled "History" to the lower left of the main Mach3 window.

-Marc
Vital System Inc.

Offline Amtrim

  • Active Member
  • Posts: 7
    • View Profile
Re: Session ID mismatch
« Reply #4 on: August 08, 2016, 02:36:13 PM »
The firmware was updated but the plugin wasn't. I put the updated plugin file in the plugins folder and the id mismatch went away