Hello Guest it is December 13, 2019, 03:57:40 PM

Author Topic: mach 4 crash  (Read 4960 times)

0 Members and 1 Guest are viewing this topic.

Offline mark4

*
  •  147 147
    • View Profile
mach 4 crash
« on: July 20, 2016, 09:30:40 PM »
Hello
i am configuring for a lathe and waiting for an updated plug in from cs-labs. so i have a windows 10 updated lenovo computer i installed mach 4 build 4.2.0.3112 pre release i just used this on a mill works good. anyway i click on the lathe icon it loaded the first time ok now it loads screen elements then loading mach motion canned elements loads about 1/3 then crashes by crashes i mean windows 10 comes up and says mach 4 cnc gui has stopped working and you have to close you cant continue. i found a work around when mach 4 is booting click on one of the menu items multiple times got me in but this didnt work every time i made my own profile i havent tried this on a different computer. i will try this on a windows 7 computer and let you know. also this computer is not hooked up to a machine or controller yet. has anybody else had this problem thank you
mark

Offline mark4

*
  •  147 147
    • View Profile
Re: mach 4 crash
« Reply #1 on: July 20, 2016, 09:59:33 PM »
note i just installed on a machine running windows vista service pack 2 seems fine will let you know on 7
mark

Offline mark4

*
  •  147 147
    • View Profile
Re: mach 4 crash
« Reply #2 on: July 23, 2016, 12:24:12 AM »
well i figured this much out i installed on a windows 7 machine and after the first start mach 4 crashes. so i started playing with the screen sets if i copy the lathe profile and leave the screen set blank same thing. if i create a profile from scratch and use the wxLathe set it opens and runs so far in windows 7 and 10 so there must be something not quite right on the original install. i am happy it is working the only concern is if i am missing something by going to a complete create profile i doubt it.
mark

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: mach 4 crash
« Reply #3 on: July 23, 2016, 02:46:57 AM »
to get better Mach4 support you have to open a ticket with Mach support

Offline mark4

*
  •  147 147
    • View Profile
Re: mach 4 crash
« Reply #4 on: July 23, 2016, 11:50:30 PM »
hi i have opened tickets with mach support but i like to start with the forum as the questions asked and answered give everybody an answer. or another way everybody can contribute if you had the problem and found a work around or fixed the issue then the community and myself can benefit. however if i don't make out with the community i do go directly to support. the next person who reads this might have the same problem and now will know ho to fix it. not to harp but this is my take on the forums if anybody has a different way of looking at it please post.
thank you
mark

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: mach 4 crash
« Reply #5 on: July 24, 2016, 01:48:37 AM »
that's about it

Offline DazTheGas

*
  •  750 750
  • DazTheGas
    • View Profile
Re: mach 4 crash
« Reply #6 on: July 24, 2016, 05:36:05 AM »
When loading you say it gets so far, watch the screen can you see the machmotion dialog load, at this point the mach core has already loaded so you know the core is fine.
Plugins are in there own right small applets that are loaded, even if not being used a part of them are loaded, I tend to remove any plugin I dont require.
Another way is to load straight into the screen editor, from the mach4 directory run    Mach4GUI /e   if you get into the screen editor this means there is something not right with the screenset that is being loaded.

DazTheGas
Theres always time for a choccy biccy

Offline mark4

*
  •  147 147
    • View Profile
Re: mach 4 crash
« Reply #7 on: July 25, 2016, 01:19:23 AM »
just thought i would try it again fresh install windows 10 computer no motion controller. it installs just fine this is the 4.0.3112 pre release run the lathe incon it fully loads the core then starts to load mach motion canned cycles this loads about 1/4 on the  bar then mach 4 hangs and windows tells you it has crashed. the work around is to create your own profile however when i first did this i didnt put anything into the screen set box not sure if that mattered still i copied the lathe profile same problem. so install then create a new lathe profile you will have to enable the sim plug in or whatever you want. this will no longer hang the machine. you will still get the mach motion canned cycles as this is related to the screen set i believe.
thank you
mark

Offline dude1

*
  •  1,253 1,253
    • View Profile
Re: mach 4 crash
« Reply #8 on: July 25, 2016, 03:00:05 AM »
I am not seeing this at all mark are you deleting the M4 file after you uninstall M4

Offline mark4

*
  •  147 147
    • View Profile
Re: mach 4 crash
« Reply #9 on: July 26, 2016, 12:31:21 AM »
thanks
i have been trying different ways to install and load in the end it still has a hang problem windows 7 or 10. i tried what you said DAZ and i got in looked around didnt find anything. quit figured it would save it didnt moved some buttons and saved. shut mach off and tried to execute from my shortcut it hangs used mach4 loader it hangs. i believe it is in the screen set and hangs on the machmotion canned cycles as this is where it hangs every time i am waiting for an update from cs-labs so i can run lathe on a machine i have a machine with mach 3 lathe but i cant make it run so am going to mach 4 and i think these canned cycles would be just what the doctor ordered but if they wont run we shall have to see. now dude1 what dont you see if you arent having the same problem as me i would like to know what you have installed i will attach my profile if i can figure out how and are you using 4.0.3112 this is a pre release might have a bug. i really want to use this if the problem can be found and rectified.
mark