Hello Guest it is January 22, 2020, 11:40:58 PM

Author Topic: Zero Tool not reading allowance  (Read 5969 times)

0 Members and 1 Guest are viewing this topic.

Re: Zero Tool not reading allowance
« Reply #10 on: July 22, 2016, 03:40:02 PM »
I tried 3rd time, touched at Z -9, dro changed to +10.???, moved to Z +15.  Go To 0, it went all the way up and came back down 1mm above model surface.
4th try, touched at Z -7, moved up to Z +26, then down to +15.  Go to 0, it went all the way up and came back down 2mm above model surface.
5th try, touched at Z -9, changed to +10.???, moved to +15.  Go to 0, it went all the way up and came back down just touching model surface!  Whoohoo ;D

But Atlas,
6th try, touched at Z -7, moved up to +11, changed to +10.???, then moved to +15.  Go to 0, it went all the way up and came back down where I had zeroed tool before auto zero?

I thought I had something...
JR

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Zero Tool not reading allowance
« Reply #11 on: July 22, 2016, 03:45:57 PM »
Quote
I tried 3rd time, touched at Z -9, dro changed to +10

Which is correct. When the tool touches your puck, it sets the DRO to the puck thickness, making Z zero the bottom of the puck.


Quote
Go To 0, it went all the way up and came back down 1mm above model surface.

It's going all the way up because of your SafeZ setting.
It sounds like your losing position somewhere between rapid moving to SafeZ, and rapid moving back down.

Try cutting your Z acceleration in half, and reduce the velocity by 25%.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Zero Tool not reading allowance
« Reply #12 on: July 22, 2016, 04:56:39 PM »
Gerry,

I dont think you got my previous reply ( 1st & 2nd try / current macro)

1st time, touched puck at Z -18, changed dro to +10, moved to +15.  Go To 0, went all the way up, hit max and stopped.
2nd time, touched puck at Z -10.2, changed dro to -7, then +10, then moved to +15.  Go To 0, went all the way up to +38,
stopped, dro changed to +28.  Never went to zero, I guess it hit limit switch.

I will send current macro for button script in a few minutes.

Thanks Again,
JR
Re: Zero Tool not reading allowance
« Reply #13 on: July 22, 2016, 05:11:48 PM »
Gerry,

I thought the button script for retract height would control that, not safe Z?
I try adjusting motor tuning for Z, and let you know what happens.

Heres copy of my current macro for button script:

CurrentFeed = GetOemDRO(818) 'Get the current feedrate to return to later
CurrentAbsInc = GetOemLED(48) 'Get the current G90/G91 state
CurrentGmode = GetOemDRO(819) 'Get the current G0/G1 state

If GetOemLed (825)=0 Then 'Check to see if the probe is already grounded or faulty
DoOEMButton (1010) 'zero the Z axis so the probe move will start from here
Code "G4 P3" ' this delay gives me time to get from computer to hold probe in place
Code "G90 G31Z-25. F4" 'probing move, can set the feed rate here as well as how far to move
While IsMoving() 'wait while it happens
Sleep(10)
Wend
ZProbePos = GetVar(2002) 'get the exact point the probe was hit
Code "G0 Z" &ZProbePos 'go back to that point, always a very small amount of overrun
While IsMoving ()
Sleep(10)
Wend
Call SetDro (2,10)' change .060 to your plate thickness and then adjust for final accuracy
Sleep (200)'Pause for Dro to update.
Code "G1 Z15. F50" 'put the Z retract height you want here, must be greater than the touch plate thickness
While IsMoving ()
Sleep(10)
Wend
Code "(Z axis is now zeroed)" 'puts this message in the status bar
Code "F" &CurrentFeed 'Returns to prior feed rate
Else
Code "(Z-Plate is grounded, check connection and try again)" 'this goes in the status bar if applicable
End If
If CurrentAbsInc = 0 Then 'if G91 was in effect before then return to it
Code "G91"
End If
If CurrentGMode = 0 Then 'if G0 was in effect before then return to it
Code "G0"
End If                     


Thanks
JR
Re: Zero Tool not reading allowance
« Reply #14 on: July 22, 2016, 05:47:48 PM »
Gerry,

I lowered Z motor as suggested, but now when I auto zero and Go To 0, Its now returning to my zero position before I auto zero.  ( Above the Puck) ?
JR

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Zero Tool not reading allowance
« Reply #15 on: July 23, 2016, 03:59:20 PM »
What version of Mach3 are you using?

Parallel port, or motion controller? If motion controller, which one?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Zero Tool not reading allowance
« Reply #16 on: July 23, 2016, 05:08:25 PM »
I have a Mach3 USB motion controller MKX-IV, Version R3.043.066 and I'm running Windows 10 on a new HP All in One.  My machine is from China, SaleCnc, XJ6090.


JR

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Zero Tool not reading allowance
« Reply #17 on: July 23, 2016, 05:24:10 PM »
Two things.

1) 3.043.066 has serious issues and should not be used, especially with probing.
2) Many chinese motion controllers do not support the GetVar() command.

Try eliminating these lines:

ZProbePos = GetVar(2002) 'get the exact point the probe was hit
Code "G0 Z" &ZProbePos 'go back to that point, always a very small amount of overrun
While IsMoving ()
Sleep(10)
Wend
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Zero Tool not reading allowance
« Reply #18 on: July 23, 2016, 05:44:18 PM »
I thought I was getting the latest version when I ordered Mach3 just 2 months ago?  There were no choices then.  Is there another version I can download?

When I return home I will try deleting those lines.

I just realized when I told Highspeed that I was using G58 offset, I was mistaken.  I have been using G54.

Also, I have had intermitten problem with my mouse & keyboard completely stop working, it just did it again.  Usually, it doesnt come back until the next day startup?

Thanks,
JR

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: Zero Tool not reading allowance
« Reply #19 on: July 23, 2016, 05:52:49 PM »
That is the latest (last) version, but it's no good. You need to use an older version. Try 3.043.062 from the FTP site, in the Mach folder.
http://www.machsupport.com/software/downloads-updates/#tabs-6
The current offset in use makes no difference.

If you're mouse and keyboard are USB, try using a different port.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html