Hello Guest it is March 06, 2021, 01:01:17 AM

Author Topic: Rapid Speed Screenset  (Read 1551 times)

0 Members and 1 Guest are viewing this topic.

Rapid Speed Screenset
« on: July 14, 2016, 06:17:33 AM »
We have a new screenset with Mach3 and now the SHIFT key on the keyboard is not allowing rapid speeds. If I press SHIFT and arrow the machine doesn't move at all, and when only arrow key, the machine moves at slow speed...

Anyone knows what that could be?

CD

Offline Tweakie.CNC

*
  • *
  •  8,664 8,664
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Rapid Speed Screenset
« Reply #1 on: July 14, 2016, 07:37:54 AM »
It may depend on your new screenset but…

Pressing the TAB key brings up the MPG window the Slow Jog Rate determines the Arrow key % jog rate and this is then overridden to 100% jog rate by the Shift + Arrow keys. If your screenset does not work this way then check out the screenset for the problem.

Tweakie.
« Last Edit: July 14, 2016, 07:39:38 AM by Tweakie.CNC »
KEEP SAFE !
Re: Rapid Speed Screenset
« Reply #2 on: July 14, 2016, 07:51:39 AM »
Ok - this is a whole new screenset, only 1 page (not even tab window)...

I understand the Slow Jog Rate, that is actually build into main screen. I can set it at any % and that works, but I don't know how to ensure SHIFT works with screenset. Do I need a certain button to enable SHIFT function on the main screen set? Or is there a hidden setting somewhere?

CD

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rapid Speed Screenset
« Reply #3 on: July 16, 2016, 01:55:25 PM »
Load a standard screenset and see if it works, if it does then it must be something in your screenset so if you attach it and the associated bitmaps (if any) I will take a look.

Hood
Re: Rapid Speed Screenset
« Reply #4 on: July 19, 2016, 04:34:27 AM »
Hi Guys, just an update!

I finally have it working. It seems like you have to tell the screenset to work in Continuous mode and then it will stay like that. I added buttons and played around until I got it working, and I'm sure that because I don't have buttons to change the Continuous mode that I can remove buttons again after I have it working.

This is what I did: I added 2 buttons on the screen: Toggle Jog Mode and Set Jog Mode Continuous, then added a LED - Continuous Jog Mode. When I start Mach3 the CONT JOG LED was off. Then I pressed the Toggle Jog Mode until Continuous LED came on, and then press Set Jog Mode Continuous. After that it seemed to work. I closed Mach3 and when I started it again the Continuous LED was already ON and everything works!

Hope this might help somebody! :)

CD