Hello Guest it is January 26, 2020, 10:23:41 PM

Author Topic: Y-Axis Home Switch not Backing Off (x-axis works fine)  (Read 1293 times)

0 Members and 1 Guest are viewing this topic.

Y-Axis Home Switch not Backing Off (x-axis works fine)
« on: June 30, 2016, 08:20:02 PM »
Hey all.  I thought I jumped the last hurdle with this machine after the external THC, but a very annoying and odd problem popped up that really has me going wtf.  Simply put, my y-axis home switch isn't backing off after its activated.  The annoying part is that the x-axis works fine, meaning it activates, and backs off till the switch releases like normal.

Things I've tried:
 - Removing the switch and operating it by hand.
 - Use shielded and unshielded wire / different gauges of wire
 - Removing the X-axis switch and only focusing on the Y
 - Re-mapping the Y-switch to the X-switch (works fine)
 - Using different ports on the G540
 - Trying different switches
 - Reversing home direction / changing home order
 - Adjusting backoff and approach velocity

Machine:
 - Mach 4 windows 10
 - Ethernet SmoothStepper
 - Gecko G540

I'm really at a loss as to why this is happening.  I have no issues with the motors changing direction during cutting and really not any other machine issues at all.  The last thing that I can think of is re-installing the motion plugin with the new beta version and re-mapping everything from the start.  I haven't seen any other threads of a machine only having an issue with 1 axis in particular, so I'm hoping that this is some kind of fluke issue.

Anyone have any ideas what would cause this?  I can post the ini settings and everything later tonight if anyone needs to see it.  Thanks

Offline DazTheGas

*
  •  752 752
  • DazTheGas
    • View Profile
Re: Y-Axis Home Switch not Backing Off (x-axis works fine)
« Reply #1 on: June 30, 2016, 08:37:31 PM »
The machine.ini would certainly help or its just guess work.

DazTheGas
Theres always time for a choccy biccy
Re: Y-Axis Home Switch not Backing Off (x-axis works fine)
« Reply #2 on: June 30, 2016, 10:23:43 PM »
Sorry for the delay, here is the ini.

Also a screenshot of how the homing tab should be set.  I was testing a few things and forget to revert the change before I left.  I get a GUI crash when I try to change it back without having the ESS hooked up at the moment.  (The Motor0Home most likely won't be saved in the ini file)

Thanks for taking the time Daz.

Offline DazTheGas

*
  •  752 752
  • DazTheGas
    • View Profile
Re: Y-Axis Home Switch not Backing Off (x-axis works fine)
« Reply #3 on: July 02, 2016, 10:16:47 AM »
Looks like your using the old plugin for the ESS try upgrading to the new plugin and setup http://warp9td.com/index.php/kunena/7-general-discussion/5589-ess-mach4-public-beta-release

there are many videos on the warp site on how o do this.

DazTheGas
Theres always time for a choccy biccy
Re: Y-Axis Home Switch not Backing Off (x-axis works fine)
« Reply #4 on: July 02, 2016, 11:22:47 AM »
Yes, I'll be going over to the new plugin shortly.  I just thought it was odd to have such a specific issue from the stable versions of mach and the plugin.  Wanted to make sure there isn't an underlying issue that is causing it considering its always just the Y axis.