Hello Guest it is January 28, 2020, 09:21:41 AM

Author Topic: MPG  (Read 3524 times)

0 Members and 1 Guest are viewing this topic.

Offline mark4

*
  •  156 156
    • View Profile
MPG
« on: June 29, 2016, 12:13:25 PM »
hello
i need help with an mpg. i have an ethernet smooth stepper connected to a cnc4pc pendant board and mach 4. i have the signals coming to mach i can see port2 input 2 and 3 in ess diagnostics so i know i have a signal. there is also a mach setup tab for mpg. the problem is i cant get the machine to jog on mpg i have tried to set up many different ways and done multiple lua script changes. allot of what i have read seems contradictory but i will take what i can get to work. all i want is a simple jog on one axis i can program the rest. please help before i have to take a hammer to Mr microchips.
thank you
mark

Offline Chaoticone

*
  • *
  •  5,634 5,634
  • Precision Chaos
    • View Profile
Re: MPG
« Reply #1 on: June 30, 2016, 10:28:54 AM »
Hello Mark,

I have attached 2 files that should be all you need if your using one of CNC4PC's MPG12 - 6 AXIS PENDANTs. If not, you will likely have to adjust to fit your needs. The script goes at the end of the SigLib table in the screen load script. This will add the necessary sigs to the SigLib table and make the CNC4PCPendant() function the first function outside of the SigLib table. It has all been tested too.

The script in the PDF and the lua file attached here are the same. You only need to use one or the other. The only reason I included the lua file is because sometimes copying and pasting from a PDF will add unwanted characters and mess up the formatting.
« Last Edit: June 30, 2016, 10:34:19 AM by Chaoticone »
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline mark4

*
  •  156 156
    • View Profile
Re: MPG
« Reply #2 on: June 30, 2016, 03:08:55 PM »
thanks for the help it mostly works however i cannot get mpg to jog an axis i am going to clear a few things up but i am sure they are not the problem. i use a c22 pendant interface board but instead of a pendant i hook directly to two rotary switches and the mpg these are on my operator control panel. the mpg is directly connected to pin 2 and 3 = to parallel port pin 2 and 3 from the ethernet smooth stepper the switches work fine with a mod for estop the mpg i turn and turn and turn. so config from ess i set up port 2 pin 2 and 3 i have seen this in the ess diagnostics screen however the screen hangs the computer as often as not right now so i want to stay out of there i mapped inputs 8 and 9 in mach 4 to the mpg and added two leds on the screen so i can see that the mpg is outputting pulses and it works. now in the mpg tab i set to mpg 0 enabled ESS/AuxEncoder0 4 counts per detent accel 20 velocity 20. that covers it ? does it possible need a plug in what files should i post so you can take a look at them or do you have any ideas thank you
mark

Offline mark4

*
  •  156 156
    • View Profile
Re: MPG
« Reply #3 on: June 30, 2016, 11:26:10 PM »
one more thing i will check out tomorrow in the pdf it says encoder 0 phase a encoder 0 phase b however in the smooth stepper input signals just below spindle encoders it says aux encoder/mpg or something like that so that is where i set the mpg a and b we shall see if that is it thank you
mark

Offline mark4

*
  •  156 156
    • View Profile
Re: MPG
« Reply #4 on: July 01, 2016, 08:02:03 AM »
well lo and behold it is morning and i set the mpg to encoder 0 and i finally have movement thank god. i wonder does anybody know about the aux encoders labeled aux encoder 0 (mpg or other) this caused me allot of grief not complaining just jazzed it works thank you
mark
Re: MPG
« Reply #5 on: July 01, 2016, 12:51:06 PM »
Did you see the new ESS driver release which addresses MPG jogging problems?

http://warp9td.com/index.php/kunena/7-general-discussion/5589-ess-mach4-public-beta-release?start=78#11147

"We just released a new Mach4 ESS plugin, that fixed MPG (Quadrature encoder input) to be used to Jog with."
Re: MPG
« Reply #6 on: July 01, 2016, 08:37:06 PM »
Mark,

Please try with the installer:

http://cnc4pc.com/Tech_Docs/M4-ESS-MPG-5X_V1.0.zip

Do not hesitate in contacting me if something is not clear.

It will configure the plugin and Mach4.  You will have to add the lua scrip to the screen manually.

Arturo Duncan
http://cnc4pc.com

Offline mark4

*
  •  156 156
    • View Profile
Re: MPG
« Reply #7 on: July 03, 2016, 12:18:56 AM »
thank you for all the replies i have finished the lua script and tested the setup. i had to do a bit of tweaking on the script but everything works fine now. i do something a little different my increment switch goes 1 .1 .01 .001 i do it this way because this is a stepper bridgeport and that is the entire resolution of the machine. the thing that threw me is i upgrade both stepper and servo machines so when i see encoder 0 the first thing i think of is X axis i have not to date done a stepper with encoders however that leads to the question with a ess if i were to add encoders to stepper motors or axises can the ess do that and what would the final config look like.
happy chips
mark