Hello Guest it is October 14, 2019, 02:56:21 PM

Author Topic: CSMIO IP/A analog spindle RPM  (Read 3375 times)

0 Members and 1 Guest are viewing this topic.

CSMIO IP/A analog spindle RPM
« on: June 19, 2016, 08:51:24 PM »
Hi All,
Have the IP/A working good and finishing up the spindle feedback. Spindle controller has analog input and analog feedback but can't seem to get the spindle RPM DRO to display (always zero). Spindle controller feedback is wired to CSMIO analog input#1 and displays in the CSMIO plugin as getting analog signal.

Also, do I need a handheld laser tach to accurately calibrate the spindle with the RPM DRO or is there any other way to confirm?
Thanks

vw

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: CSMIO IP/A analog spindle RPM
« Reply #1 on: June 20, 2016, 05:55:47 AM »
Sorry replied in wrong post, will look at this post and reply in a bit

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: CSMIO IP/A analog spindle RPM
« Reply #2 on: June 20, 2016, 06:01:40 AM »
To get spindle feedback to Mach you need to use an Index pulse, either from and encoder on the spindle or from a slotted disc/opto or hall sensor or whatever.

You could likely get your analogue signal to work but  I think it would have to be via the macropump or a brain and write to a user DRO.

There shouldn't be any calibration required if your VFD has a linear output.

Hood
Re: CSMIO IP/A analog spindle RPM
« Reply #3 on: June 20, 2016, 03:44:49 PM »
Thanks Hood.
VFD is a KEB F5 with no easy way to get the current parameter setup so I don't know the frequency division to set exact spindle ratios.
Ordered a laser tach today to get actual spindle RPM then I can adjust the spindle ratio.
 

Re: CSMIO IP/A analog spindle RPM
« Reply #4 on: January 10, 2017, 02:17:47 AM »
i have the same parts (csmio-a and keb) with gearing and spindle index sense.

how is the right  setting in the pulley menu?


the  maxium motor rpm is 3000 and my ratio  is 2:1 (spindle speed 1500 rpm)

so i must setting the pulley menu to min speed 0 and max speed 1500 with ratio 2? is this right?

or is the setting min speed 0 and max speed 3000? and is the ratio 2 or 0.5?