Author Topic: CS Labs Uploader  (Read 1529 times)

0 Members and 1 Guest are viewing this topic.

Offline sankos

  • Holding
  • Posts: 2
    • View Profile
CS Labs Uploader
« on: June 19, 2016, 08:01:17 AM »
Please bear with me this is a long one. I bought a csmio/ip-a some while ago to use with an Adventech panel mounted computer this had Windows XP 32bit . When I attempted to use the firmware uploader the loading screen remained blank and it came up with an error saying there was a "flointing point division by zero". I did eventually get it to work but it was so problematic I gave up and tried a different computer which has the same problem. Sometimes by clicking inside the blank panel of the loader it will take me to the directory where the firmware is stored and eventually I was able to install the firmware. After several hours of setting it up Mach3 suddenly stopped working and on attempting to restart came up with errors suggesting the .ini file was corrupt which indeed it was all the settings including those of the controller had either been reset or vanished. I uninstalled the CS Labs software and tried to reinstall but again got the "floating point division by zero" problem. Out of curiosity I tried this on my laptop and got the same result, but on another laptop it will work just fine with the screen appearing as normal, it also works on my desktop computer. So to recap I can not get the firmware uploader to work on 2 out 5 computers. The laptops and the desktop as well as the computer I am using on the machine all use Windows 7 x64 Enterprise and the results are exactly the same regardless as to whether or not the controller is connected or not or the LAN adapter settings. Yes Microsoft Framework is installed. I am at total loss now, clealry the controller is fine and the problem seems to lie with my computer and or its settings, any advice would be gratefully recieved. Thanks in advance. Dave

Offline Hood

  • Mach4 Alpha
  • Posts: 25,774
  • Carnoustie, Scotland
    • View Profile
Re: CS Labs Uploader
« Reply #1 on: June 20, 2016, 05:57:58 AM »
Probably best to ask CS Lab if they have any ideas.
Hood

Offline sankos

  • Holding
  • Posts: 2
    • View Profile
Re: CS Labs Uploader
« Reply #2 on: June 21, 2016, 05:26:20 PM »
I decided to fit another motherboard to my Bridgeport and there is no problem with this one, I must be just unlucky to have used a board
that was somehow incompatible with the CS Labs uploader so it is back to setting it all up and this time I will make a copy of the configuration settings. Thanks for your help Dave