Hello Guest it is July 04, 2022, 12:28:48 PM

Author Topic: Utter PKey57CNC install FAIL  (Read 4681 times)

0 Members and 1 Guest are viewing this topic.

Utter PKey57CNC install FAIL
« on: June 18, 2016, 10:39:25 AM »
Hello all,

I am a business owner who infrequently needs to make CNC products in house, I have a Gate ECM2 CNC Mill running on Anilam that I can operate with confidence so I'm not new to cnc.

I have little to no electronic experience, but do have an OK basic understanding of what needs to be done with both Mach3 and Pokeys products based on about 3 weeks of research and study of the manuals and demo usage.

Now the hardware has arrived and been plumbed in on the bench top the problems have begun.

the following is an outline of spec, the processes I have used and the problem/questions.

Outline of my purchased setup and machine conversion:-

Boxford 240 TCL, to be modernised with,

Pokeys57CNC controller board and peripherals (PoExtBusOC16, PoExtBusRe, Ponet kbd48CNC, PoMPG 80mm, Adaptor 10-5, Adaptor 20-20LC, ETC)

Mach3 Official licence on Windows 7 32Bit Dell Optiplex 780, with 1gb Graphics card (Every port you could imagine is on the back of this machine, PP, USB 2.0 x6, etc)

Leadshine Easy Servo, ES-D808 Drives with matched motors, ES-M23480 8.0nm hold, all required extensions and a 48v ac to dc RSPS as sugested by the supplyer.

To reuse, GEC Gemini drive 0-10v analogue speed input, 240v fwd/rvs contactor enguaged by PoXetBusRE, and a spindle position eye and plate to be used for threading/rpm etc.

All these parts should work together from my research, and well I believe.

Heres follows the problem I actually need help with.

I have installed (Correctly) the Pokeys software, the Mach3 Software ande Licence (Restarted pc as required).

I have opened Pokeys software and attached Pokeys57CNC via USB and 13.8v RSPS, then run the firm ware update per the dialogue that appeared, then initialised the kbd48CNC keyboard per instructions and sent to device etc. I tested the keyboard in the dialogue box and all responds as should.

I closed Pokeys software, then opened Mach3, ( I have been told by po software guy to do this way) then attempted to use the keyboard 48CNC and the keys do NOTHING, Nothing (almost 170 euros of nothing sic : :) )

Checking the plugins the Pokeys mach3 one was not present in the folder in C:\Mach3, Pokeys software is NOT installing automatically. So I dragged and dropped per instructions, then restarted Mach3 and opened the Plugins Config dropdown, ticked green and clicked config, the device didnot appear in the list so I clicked add new, clicked Pokeys57CNC and ok, then  restarted Mach3.

Upon restarting mach3 the kbd48cnc still does 168 euro of nothing  ;D

So I have tried various settings, several re-installs of all software, connected to just usb, connected to just 10/100 ethernet, connected to both. etc etc etc.

The only thing I haven't done yet is bin 604 euro of junk gear. >:D

Don't know if I should laugh or cry.

Support seams friendly, but its all so gratingly slow, I have all the hardware I need now, and want the machine plumbed in and commissioned by end of next month so I can make a little ££ back and fix my Manual lathe.

I think ether Pokeys software is broken/not auto adding things, or Mach3 is broken or not working on my PC, or possibly the instructions are lacking key info on how to use pokeys settings to make kbd48cnc board work, I cant seem to find the file location for the kbd48cnc config xml to check it or place it into?!

I appreciate that I'm probably at the consciously incompetent stage with all this but I have to learn some how, right?

Any one else experience this?
If so how/can you fix this?
Would Windows 8, or XP compatibility mode fix?
does anyone have a similar setup that they can send me config files for etc?

As of today update 4.2 is installed with no change to the function.

Am I doing something wrong?

« Last Edit: June 18, 2016, 10:43:21 AM by Fresh Fabs »

Offline NeoTO

  •  504 504
    • View Profile
    • PoLabs
Re: Utter PKey57CNC install FAIL
« Reply #1 on: June 18, 2016, 03:18:03 PM »
1. PoKeys plugin for Mach3 is not installed: the PoKeys plugin for Mach3 is selected to be installed by default to C:\Mach3\Plugins folder. If you just run the PoKeys setup, the PoKeys plugin will be copied to that folder.
2. kbd48CNC not working: there is a manual available for kbd48CNC keyboard on the kbd48CNC product homepage (https://www.poscope.com/index.php?route=product/product/download&download_id=50&product_id=53). The manual guides you through the installation of the keyboard (it needs to be registered in the PoKeys software first, as you did). The essential step to making it work is to either manually configure the functions of each key or simply load the configuration file for the plugin, as described in the manual.

Regarding 'So I dragged and dropped per instructions', which instructions are you referring to?
Regarding the slow support - since yesterday (17.6.2016), we exchanged 8 messages. And it is weekend.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Utter PKey57CNC install FAIL
« Reply #2 on: June 18, 2016, 06:12:22 PM »
Hello NeoTO,

Many thanks for your reply.

I know that I have a support ticket open in your website, I have replied to your last message and taken all the actions you have suggested but with no fix sadly.

I was posting here to see if anyone who also uses your software and devices had any fixes, work around or suggestions.

I did a lot of research, read all the manuals several times and tried out the demo software on my PC before committing to the purchase from your website. Sadly now the hardware is here I can not make it work due to the issues outlined in my Ticket. I have followed the instructions as best as humanly possible and used the exact software you linked to. The answer to the other questions are in my ticket on your site.

I hope that maybe some others can still add input or help also.

Re my "Support seams friendly, but its all so gratingly slow, I have all the hardware I need now, and want the machine plumbed in and commissioned by end of next month so I can make a little ££ back and fix my Manual lathe." sentence. Please do not get insulted by the syntax, the point I was trying to make may sound better with good punctuation and was only meant to be friendly whilst conveying my situation.

"The support is friendly"  :)
"The process of making the hardware work is gratingly slow"
"I need this thing working asap or I lose money from my business"

I appreciate the responses, its the weekend for me too, but I'm trying to get this sorted as soon as possible to avoid a disaster.

kind regsrds,

Jon Davis
Fresh Fabrications Ltd

Offline NeoTO

  •  504 504
    • View Profile
    • PoLabs
Re: Utter PKey57CNC install FAIL
« Reply #3 on: June 19, 2016, 01:24:28 AM »
Hi, Jon

Regarding the plugin - the PoKeysDevice_DLL.dll​​ is a communication library that needs to be left where it is. It is registered in your system as ActiveX/COM library, which is then used by other applications to access the PoKeys device.
If 'PoKeys plugin' option appeared in the Mach3 plugins list before you used the file from the previous message, then your PoKeys setup did the job and copied the correct file to a correct location. You should not use this library as Mach3 plugin by copying it to Mach3's Plugins folder manually. The manual for Mach3 plugin is available here: https://www.poscope.com/index.php?route=product/product/download&download_id=83&product_id=87

Since the plugin supports multiple devices and each device must be configured to someone's needs, Mach3 will not just use any device by default. You must add it and configure it. Make sure that you don't have any other application open, that is accessing the PoKeys device.

I suggest reading the following blog posts:
- http://blog.poscope.com/pokeys57cnc-getting-started/
- http://blog.poscope.com/mach3-tutorial-first-steps/
- http://blog.poscope.com/mach3-setup-tutorial-first-movements/
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
Re: Utter PKey57CNC install FAIL
« Reply #4 on: June 19, 2016, 11:41:41 AM »

this morning after receiving your kind message, and having read all the links, I decided to do another uninstall and reinstall of the pokeys software. The data you sent had been read previously and confirmed my hypothesis of what I was supposed to be doing.

As you have said the Pokeys has found the device, and has registered the kbd48cnc board. As you know this was never the problem.

This morning I decided to have one last go at uninstalling the pokeys software then reinstalling. before I did this I once again checked the C:\Mach3\PlugIns folder and removed the Pokeys.dll file that you provided, (to insure that the file was not there)

I then closed everything as I always do before a new install, and again turned off windows fire wall.

Once I had reinstalled the pokeys software it automatically looked for and found an update, which was then installed. I closed Pokeys, checked Task manager for running programs which was clear, then opened C:\Mach3\PlugIns folder.

This time, since the second update of Pokeys software, Pokeys DID install Pokeys.dll, I am overjoyed.... ;D

There was still a STOPPED state on the 57cnc board, but once I inverted the E-Stop in the Mach3 Pokeys Plugin, (rather than in Pins & Ports) the Reset Key on kbd48cnc functioned perfectly.

My supposition is that Something failed in the previous Update of Pokeys software, as it seemed to freeze after the updates or installs. This time it did not??! Thankfully. As soon as I opened Mach3 the configure file held the name pokeys57cnc and the Configure click box and subsequent dialogues opened as they should have, Also for the first time the "Motion Controll Plugin Sensed" Dialogue box appeared. this is how I knew it was working. I had looked for this the whole time.

Perhaps My PC is fighting installs of things, perhaps the Pokeys update freezing was the problem. I certainly did not find any other ports trying to access the Pokeys57cnc in PC ports settings and connections?!

​The frustration was that I have not done anything wrongly or differently but now it works.

I am very happy that this is now working as this was very stressful for me.

Again I thank you for your friendly help.
Re: Utter PKey57CNC install FAIL
« Reply #5 on: June 21, 2016, 05:49:34 AM »
Hello, understand this kind of frustration, but ultimately would say, you were doing something wrong. Most controllers are not plug and play and regardless of "research", require some trial and error if you have not used before. The estop inversion and proper mach setup of motors is a must for movement. Pokeys is dependent upon other hardware to work properly.
A word to the wise, troubleshoot all connected devices and spend a little more time gathering info before trashing a company and hardware. 99% of these types of threads and issues are user error.
Re: Utter PKey57CNC install FAIL
« Reply #6 on: June 21, 2016, 06:50:40 AM »
Hi rodm717,

Thanks for your sage wisdom.

Please do point out specifically where I trashed the company.sic   ::)

This was a new pc dedicated to the cnc machine, NO other devices were connected, none. The only software installed relates to the cnc, and i always close all other programs when i install anything else on the system to be safe, by all I mean all and then a task manager check, and before you add some retort about shutting down the pc and restarting, yes I did that to where necessary per instructions or on screen prompts. I KNOW that it's not plug and play, I'm not mentally sub normal. Trial and error is indeed needed for the pins and ports and the active high low states, and as I found not masively hard to deal with.

The problem was that pokeys software didn't auto install the Pokeys.dll file, I had to use "trial and error" to understand why this was happening, and to see if i could make it work withoilut the .dll auto installing, not to make the device work. Trial and error didn't make it auto install I had NO PROBLEM configuring the device ONCE pokeys updated, didn't freeze after update, and showed in Mach3. It only became apparent to me that it wasn't freezing/crashing after install when upon clicking the ok button after the 7th install attempt pokeys STAYED OPEN.

(Edited out some comments - Tweakie).
« Last Edit: June 21, 2016, 09:02:27 AM by Tweakie.CNC »

Offline NeoTO

  •  504 504
    • View Profile
    • PoLabs
Re: Utter PKey57CNC install FAIL
« Reply #7 on: June 21, 2016, 12:07:23 PM »
Guys, no need to start an argument here.

We managed to solve the problem Jon had and we will look into it in more details to determine what went wrong the first 'six' attempts.
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope