Hello Guest it is November 24, 2020, 12:29:57 PM

Author Topic: Sample gcode need larger scale  (Read 6386 times)

0 Members and 1 Guest are viewing this topic.

Sample gcode need larger scale
« on: June 15, 2016, 02:20:00 PM »
FROM ANOTHER NOVICE

I an trying to run a sample gcode for the first time, after just setting up a XJ6090 cnc router from Salecnc, with Mach3.  It produced a miniture model, so how do I change scale to correct size?
Re: Sample gcode need larger scale
« Reply #1 on: June 15, 2016, 09:24:07 PM »
You say miniature, like maybe the G code was written in inch units and your machine is set up in mm? There is a g-code to select units, look it up in g-code list.  Is it only a little bit smaller?  Check whether your stepper drivers are set for micro stepping and that steps per unit of travel matches in Mach 3
Re: Sample gcode need larger scale
« Reply #2 on: June 15, 2016, 09:50:12 PM »
Thanks for the reply.  This was the famous Roadrunner sample gcode in Mach3, produced about a 1/4" figure.  I am setup in mm, so could be unit selection.  How would I check stepper drivers for micro stepping?  Steps per travel are good.
Re: Sample gcode need larger scale
« Reply #3 on: June 15, 2016, 11:09:26 PM »
MM is G21.  Can this be added to sample gcode anywhere before coordinates begin?  I dont know anything about writing gcode....

Offline Tweakie.CNC

*
  • *
  •  8,550 8,550
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Sample gcode need larger scale
« Reply #4 on: June 16, 2016, 01:48:12 AM »
The roadrunner Gcode file was compiled for a machine set-up in imperial (Inch) units.

If you add the code G20 to the beginning of the roadrunner Gcode file Mach3 (which you have set-up in mm units) will perform the conversion and your machine will reproduce the work to the intended dimensions.

Tweakie.
KEEP SAFE !
Re: Sample gcode need larger scale/ To Tweakie
« Reply #5 on: June 16, 2016, 07:57:05 AM »
Tweakie,  Is it converting the gcode or my machine setup?   So, when I want to work in inches, (my machine came from the factory in mm}, where and when do I change settings?

I was expecting to get a boxed license for Mach3 from the factory, but did not.  They sent me a file ( NCUsb.Pod }, driver to install in Mach3 folder.  I had already downloaded your demo version to practice on and loaded my factory parameters.
I have a Mach3 USB motion controller MKX-IV, and I'm running Windows 10 on a new HP All in One.  After I make sure my machine works satisfactory, I'll order the license. I hope this is Kosher.

Offline Tweakie.CNC

*
  • *
  •  8,550 8,550
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Sample gcode need larger scale
« Reply #6 on: June 16, 2016, 08:18:01 AM »
Your Mach3 set-up is just fine left as it is in mm.

If a Gcode file has been compiled in mm units then it should have a G21 at the start of the code.
If a Gcode file has been compiled in inch units then it should have a G20 at the start of the code.

Your machine set-up will not be changed by the G21 / G20 it is just the Gcode units that are converted during the program run. Unfortunately the roadrunner file was compiled in inches but they forgot to include the G20 (probable done just to fool us all  :) ).

More details regarding this are in the Mach3 Manual http://www.machsupport.com/help-learning/product-manuals/

Once you are satisfied that Mach3 works to your expectations then order the license, it is perfectly in order to continue using Mach3 in demo mode for as long as you wish.

Tweakie.
KEEP SAFE !
Re: Sample gcode need larger scale
« Reply #7 on: June 16, 2016, 08:49:49 AM »
MUCH APPRECIATED.  I have been reading the manual till my eyes are crossed.... I still have a problem when I home machine, it hits home switch and stops.  It does not back off.  I thought that Home Offsets did that, and had set at 5mm?
When I homed, I noticed the Machine Coord. reading 5mm , I think on all axis?
Re: Sample gcode need larger scale
« Reply #8 on: July 23, 2016, 07:16:12 PM »
Hey JR,

Just came across this post.  I know it's a bit older than the other one we've been discussing, but I'll take a crack at this one too if it's still an issue for you.

The homing routine _should_ run the axis at a relatively slow rate until the switch is contacted, then back off a _slight_ amount until the switch is no longer active.  Setting the Home Offsets only updates the DROs to the offset value as I understand it.  It does not actually move the axis that amount.  I'd have to play with this to confirm, though.  But my machine also uses combined limit/homing switches (a limit switch at each end wired to the same input and configured for the same pin on all three inputs in the Config/Port & Pins screen on the Inputs tab) so it may behave differently if you have a separate home switch wired to a different pin than the limit switches.

Let me know.

Stephen "Highspeed" Kruse
Re: Sample gcode need larger scale
« Reply #9 on: July 24, 2016, 04:43:21 PM »
Highspeed,

I ran across the page under config. plungins, and remembered you said your maching had combined limit / homing switches.  Under Options single was checked, but
there was a dual setting, so I switched it and Low and Behold, when I rehomed it backed off the home switch, like it was suppossed to do....

Thanks Again,
JR